App does not save Mail Server Account Settings

Hi Folks,

how do I get Mail to save the preferences of my E-Mail Account? Every time I set up or edit my account (and hit “save”) and go back to inbox I cant send or receive e-mails because my preferences under “edit account” are either reset or forgotten. Am I missing something? I use posteo.

Any help would be greatly appreciated.

Unfortunately you’ve ignored to provided DETAILED information about your environment, the used software versions, Nextcloud and web server logs etc., etc. Without this essential information it won’t be possible to give you a reliable answer.

Have you already used the search function of this forum to find a solution for your problem? It seems that similar issues have already been addressed in the past, e.g.

https://help.nextcloud.com/search?q=posteo

1 Like

Hi j-ed,

thank you for providing me with additional information. I’m a newbie, so bear with me:

a) Environment:
sorry, I don’t understand what and how to provide here
b) Software Versions:

  • PHP 7.2,
  • Nextcloud 19.0.3,
  • Latest stable Mail App
  • any other software of relevance here??

c) Nextcloud log:

[mail] Fatal: OCA\Mail\Exception\ServiceException: IMAP errorError connecting to mail server. at <>

  1. /data/web/1/000/060/221/245148/htdocs/nextcloud/apps/mail/lib/Service/MailManager.php line 101
    OCA\Mail\IMAP\MailboxSync->sync(OCA\Mail\Account {})
  2. /data/web/1/000/060/221/245148/htdocs/nextcloud/apps/mail/lib/Controller/PageController.php line 119
    OCA\Mail\Service\MailManager->getFolders(OCA\Mail\Account {})
  3. /data/web/1/000/060/221/245148/htdocs/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 170
    OCA\Mail\Controller\PageController->index()
  4. /data/web/1/000/060/221/245148/htdocs/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 100
    OC\AppFramework\Http\Dispatcher->executeController(OCA\Mail\Controller\PageController {}, “index”)
  5. /data/web/1/000/060/221/245148/htdocs/nextcloud/lib/private/AppFramework/App.php line 137
    OC\AppFramework\Http\Dispatcher->dispatch(OCA\Mail\Controller\PageController {}, “index”)
  6. /data/web/1/000/060/221/245148/htdocs/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php line 47
    OC\AppFramework\App::main(“OCA\Mail\Controller\PageController”, “index”, OC\AppFramework\ … {}, {_route: “mail.page.index”})
  7. <>
    OC\AppFramework\Routing\RouteActionHandler->__invoke({_route: “mail.page.index”})
  8. /data/web/1/000/060/221/245148/htdocs/nextcloud/lib/private/Route/Router.php line 297
    call_user_func(OC\AppFramework\ … {}, {_route: “mail.page.index”})
  9. /data/web/1/000/060/221/245148/htdocs/nextcloud/lib/base.php line 1012
    OC\Route\Router->match("/apps/mail/")
  10. /data/web/1/000/060/221/245148/htdocs/nextcloud/index.php line 37
    OC::handleRequest()

GET /index.php/apps/mail/
from 37.201.5.21 by admin at 2020-09-26T11:28:42+00:00

Please let me know if there is anything else I need to provide. And sorry for the lack of information in my initial posting. I’m a newbie and assumed there was something obvious I was missing. And yes, I tried to search the forum. Nothing seems similar to me. I have this problem with all Mail Accounts I try to set up.

Which settings are “forgotten”?

IMAP and SMTP Password. Upon initial setup, e-mails are retreived from my mail server. Sending and receiving e-mails after initial setup does not work. Checking the settings of the e-mail account shows that the fieds for imap/smtp passwords are empty.

Hi Cristoph,

apparently it is not as easy to get this App up and running as described in the admin documentation. I also get this message:

`> KItinerary binary adapter is not available, can’t extract information

Is this relevant? Is there anything obvious I am missing? I’m digging around this Forum and can’t find anything that points me into the right direction. I also seem to have som legacy account information stored that i would like to have removed. When composing a new message I get to choose an account that is no longer installed, which concerns me for security reasons.

I’m afraid I have to reinstall my whole nextcloud installation and avoid using the Mail App. :frowning:

They are empty because we don’t expose the saved password to the user. However, that doesn’t mean the app forgets and of those settings. The password is NOT lost.

1 Like

This is literally a warning. Ignore it.

The issue you are facing: I can’t send E-Mails.

Is this the first time you’ve seen this error? (Y/N) : N

Steps to replicate it:

  1. Add new E-Mail account
  2. Manually configure E-Mail account details
  3. Check E-Mail account and see that E-Mails were retreived
  4. Click “New Message”
  5. Select E-Mail account in “From” field (there is a second account, have no idea why)
  6. Enter E-Mail address of recepient
  7. The button “send” cannot be pushed.
  8. This does not happen, when I reply to an E-Mail

The output of your Nextcloud log in Admin > Logging :

[mail] Fatal: OCA\Mail\Exception\ServiceException: IMAP errorError connecting to mail server. at <<closure>>

0. /data/web/1/000/060/221/245148/htdocs/nextcloud/apps/mail/lib/Service/MailManager.php line 101
   OCA\Mail\IMAP\MailboxSync->sync(OCA\Mail\Account {})
1. /data/web/1/000/060/221/245148/htdocs/nextcloud/apps/mail/lib/Controller/PageController.php line 119
   OCA\Mail\Service\MailManager->getFolders(OCA\Mail\Account {})
2. /data/web/1/000/060/221/245148/htdocs/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 170
   OCA\Mail\Controller\PageController->index()
3. /data/web/1/000/060/221/245148/htdocs/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 100
   OC\AppFramework\Http\Dispatcher->executeController(OCA\Mail\Controller\PageController {}, "index")
4. /data/web/1/000/060/221/245148/htdocs/nextcloud/lib/private/AppFramework/App.php line 137
   OC\AppFramework\Http\Dispatcher->dispatch(OCA\Mail\Controller\PageController {}, "index")
5. /data/web/1/000/060/221/245148/htdocs/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php line 47
   OC\AppFramework\App::main("OCA\\Mail\\Controller\\PageController", "index", OC\AppFramework\ ... {}, {_route: "mail.page.index"})
6. <<closure>>
   OC\AppFramework\Routing\RouteActionHandler->__invoke({_route: "mail.page.index"})
7. /data/web/1/000/060/221/245148/htdocs/nextcloud/lib/private/Route/Router.php line 297
   call_user_func(OC\AppFramework\ ... {}, {_route: "mail.page.index"})
8. /data/web/1/000/060/221/245148/htdocs/nextcloud/lib/base.php line 1012
   OC\Route\Router->match("/apps/mail/")
9. /data/web/1/000/060/221/245148/htdocs/nextcloud/index.php line 37
   OC::handleRequest()

GET /index.php/apps/mail/
from 37.201.5.12 by admin at 2020-09-30T17:19:27+00:00```

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

note: this file sits at: /path/to/nextcloud/config It seems to be relatede to the nextcloud mail account, not this specific mail account im trying to set up.

<?php
$CONFIG = array (
  'instanceid' => 'xxx',
  'passwordsalt' => 'xxx',
  'secret' => 'xxx',
  'trusted_domains' => 
  array (
    0 => 'xxx',
  ),
  'datadirectory' => 'xxx/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '19.0.3.1',
  'overwrite.cli.url' => 'xxx',
  'dbname' => 'xxx',
  'dbhost' => 'xxx',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'xxx',
  'dbpassword' => 'xxx',
  'installed' => true,
  'theme' => '',
  'loglevel' => 2,
  'maintenance' => false,
  'mail_from_address' => 'mail',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'NOT THE DOMAIN I ENTERED FOR THIS MAIL ACCOUNT',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'NOT THE HOST I ENTERED FOR THIS MAIL ACCOUNT',
  'mail_smtpport' => '465 ',
  'mail_smtpname' => 'NOT THE NAME I ENTERED FOR THIS MAIL ACCOUNT',
  'mail_smtppassword' => 'NOT THE PWD I ENTERED FOR THIS MAIL ACCOUNT',
  'mail_smtpsecure' => 'ssl',
);

The output of your Apache/nginx/system log in /var/log/____ :

could not locate file

The recipient is not selected. click it in the dorpdown. Then the send button will change to active.

This is so embarassing. Thank you.

It’s not. The UX of the recipient selection is just bad, you’re by far the only one: https://github.com/nextcloud/mail/issues/2769

1 Like