Apache2 zeigt PHP-Quellcode statt sie auszuf├╝hren

Hallo zusammen,

Ich habe eine Sub-Domain f├╝r Nextcloud angelegt (cloud.meindomain.de).

Dazu habe ich folgende Apache2-Konfigurationen erstellt.

Einmal ohne SSL:

<VirtualHost *:80>
   ServerName cloud.meindomain.de
   ServerAlias cloud.meindomain.de
   ServerAdmin hostmaster@meindomain.de

   DocumentRoot /var/www/***/nextcloud
   ErrorLog /var/log/apache2/cloud.meindomain.de-error.log
   CustomLog /var/log/apache2/cloud.meindomain.de-access.log combined

   RewriteEngine on
   RewriteCond %{SERVER_NAME} =cloud.meindomain.de
   RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>

mit SSL

<IfModule mod_ssl.c>
   SSLUseStapling on
   SSLStaplingCache shmcb:/var/run/ocsp(128000)
<VirtualHost *:443>

   SSLCertificateFile /etc/letsencrypt/live/cloud.meindomain.de/fullchain.pem
   SSLCertificateKeyFile /etc/letsencrypt/live/cloud.meindomain.de/privkey.pem
   Include /etc/letsencrypt/options-ssl-apache.conf

   Protocols h2 h2c http/1.1

   Header add Strict-Transport-Security: "max-age=15552000;includeSubdomains"

   ServerAdmin hostmaster@meindomain.de
   ServerName cloud.meindomain.de
   ServerAlias cloud.meindomain.de
   SSLEngine on
   SSLCompression off
   SSLOptions +StrictRequire
   SSLProtocol -all +TLSv1.3 +TLSv1.2
   SSLCipherSuite ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384
   SSLHonorCipherOrder off
   SSLSessionTickets off
   ServerSignature off
   SSLStaplingResponderTimeout 5
   SSLStaplingReturnResponderErrors off
   SSLOpenSSLConfCmd Curves X448:secp521r1:secp384r1:prime256v1
   SSLOpenSSLConfCmd ECDHParameters secp384r1
   SSLOpenSSLConfCmd DHParameters "/etc/ssl/certs/dhparam.pem"
   LogLevel warn
   CustomLog /var/log/apache2/cloud.meindomain.de-access.log combined
   ErrorLog /var/log/apache2/cloud.meindomain.de-error.log
   DocumentRoot /var/www/***/nextcloud

<Directory /var/www/***/nextcloud/>
   Options Indexes FollowSymLinks
   AllowOverride All
   Require all granted
   Satisfy Any
</Directory>

<IfModule mod_dav.c>
   Dav off
</IfModule>

<Directory /var/nc_data/>
   Require all denied
</Directory>

<Files ".ht*">
Require all denied
</Files>

   TraceEnable off
   RewriteEngine On
   RewriteCond %{REQUEST_METHOD} ^TRACK
   RewriteRule .* - [R=405,L]
   SetEnv HOME /var/www/***/nextcloud
   SetEnv HTTP_HOME /var/www/***/nextcloud
<IfModule mod_reqtimeout.c>
   RequestReadTimeout body=0
</IfModule>
</VirtualHost>
</IfModule>

Nun habe ich das Problem, beim Aufruf von https://cloud.meindomain.de der PHP-Quellcode ausgegeben wird. Ich kann die Installation von Nextcloud nicht starten.

Mein System:
Ubuntu 20.04
Apache 2.4
PHP 7.4
MariaDB 10.3

Woran kann das liegen?

Hi @Skayritares

Versuche mal folgendes:

sudo apt install libapache2-mod-php

Und ├╝berp├╝fe ob alle ben├Âtigen PHP-Module installiert und aktiviert sindÔÇŽ

https://docs.nextcloud.com/server/latest/admin_manual/installation/example_ubuntu.html

Ich habe es inzwischen hinbekommen.
Habe diesen Befehl ÔÇťa2enmod php7.xÔÇŁ eingegeben, Apache2 neu gestartet und es hat funktioniert.

Also Danke euch allen.

1 Like