Anyone used the Rock64 Image on a Popcorn Hour Transformer?

ncp

#1

Has anyone tested the Rock64 image of NCP on a Popcorn Hour Transformer ( https://www.cloudmedia.com/?product=popcorn-hour-transformer-nas )? It’s basically a Rock64 with a onboard SATA adapter, like the Odroid HC1/2 series.

I bought one a bit ago and want to move to it for my NCP instance.


#2

So I gave it a try today. All seems to work fine. I did have to manually add the SATA drive to fstab file so that it mounts at boot time. NCP web interface seems to work fine and sees the mount point. I was able to move my data directory, database directory and swap file to the SATA drive.

I think I’ll buy a nice big 4-5 TB 2.5" hard drive and set up the Transformer as my main NCP box.


#3

had some strange issues tonight. I reflashed my eMMC card on the Transformer with the December image of NCP (for the Rock64). I set up my SATA drive and had it mounted properly in fstab. Crated an ext4 partition on that drive. Used the web interface to move data to the SATA drive, all went well. Then, I tried to move the database to the SATA driver. Got his error: /mnt/data is not empty. What’s the story? Do I have to move the database first, and THEN the data directory?


#4

@nachoparker, how does the nc-init reset work? Do I enter my current user (NCP) and my current NCP user password to start the process? Will it reset both the data directory and database directory back to factory? Does it recreate the web interface and user passwords, just like the initial install?

Just wondering how this works as I may try to do an nc-init instead of refreshing my eMMC to fix he above issue.


#5

hi, I just saw this thread

Just move the database to /mnt/database, or any folder that is empty or doesn’t exist (will be created).

In any case, your NCP instance is working well, right?

nc-init only resets your Nextcloud instance, it will not remove your datadir if you moved it, it willdelete users, calendars, apps, and so on like a fresh install


#6

Ok, this is interesting. It did not move the database, I got an error saying the disk is not empty. I was putting in /media/ncpdisk (which is where the SATA drive is mounted). Once I put in /media/ncpdisk/database, it worked fine.

Still have to move the data directory and swap over to the hard drive. Working on setting everything up now. Will post back here in a few days once I have everyting set up. So far, it’s looking very good.

I like the new web interface in 1.0.1


#7

thanks Jeffery!


#8

So, all is working well now. Transformer NAS solution from Popcorn Hour. Used the December 2018 image for the Rock64. I did have to manually setup the SATA drive in Armbian, but I expected that.

I put a 5TB 2.5" hard drive in the Transformer as a data drive. Using the eMMC to boot NCP from. Moved the Database, the Data drive, and Swap to the HDD.

Seems a bit faster than the RPi that I was running. Web interface is still slow, but not as bad.

All in all, Great Work @nachoparker! Thank you for putting all this together for the community.


#9

That seems like a pretty cool box. Does anyone know a European reseller so that I don’t have to order from what seems to be a company in Malaysia (and thus offers no return option / warranty etc.)?

Edit: Web-interface still slow with NC15? It seems much improved on my hosted server, so I guess it would also run better on these relatively slow home-boxes.


#10

I have purchased directly (I’m on the US) and had not problems. I did get a defective eMMC card from one order and was able to return it for replacement with no issues.

I am still on NextCloud 14. Nacho has not updated NCP for Nextcloud 15 yet. I could update directly from the Nextcloud interface, but I’ve had issues with that before. Nacho does not recommend using the native Nextcloud update process. He has built an update process into the NCP web management interface and recommends using that.

@nachoparker, any updates on when you will support the upgrade to NC15?


#11

It’s already in devel. If all is good I’ll release it for everyone in a couple days

If you want to go ahead and help make this happen faster run sudo ncp-update devel and verify that all is ok :wink:

Then you can run nc-update-nextcloud to update manually to 15.0.1 or if you have nc-autoupdate-nc active it will happen within a day.


#12

Darn, just saw this. I am heading out of town for a bit and won’t get a chance to do this until I get back…

I hope that by then, you’ll have all the bugs worked out and have it in production.

Thanks again!