AnfÀngersupport bei der Installation von Nextcloud gesucht - trusted_domains

Hallo liebe Community,
ich habe ein Problem bei der Konfiguration der trusted_domains.

Aufruf ĂŒber meine Website liefert immer:

Zugriff ĂŒber eine nicht vertrauenswĂŒrdige Domain

Bitte kontaktieren Sie Ihren Administrator. Wenn Sie Administrator sind, bearbeiten Sie die „trusted_domains“-Einstellung in config/config.php. Siehe Beispiel in config/config.sample.php.

Ich habe die config.php entsprechend angepasst, leider ohne Erfolg.
Kann mir hier jemand auf die SprĂŒnge helfen, was an der Konfiguration falsch ist?
Bin ein blutiger AnfÀnger
 Vielen Dank im Voraus.

Hallo, Bitte nennen sie die Art des Medizinischen Notfalls :wink:

Wichtig sind 2 dinge den Link Über den du rein wisst

Und die config.php

Beispiel:

www.ichwillinmeinecloud.net

dann sollte in der config.php stehen

‘trusted_domains’ =>
array (
0 => ‘XXX.XXX.XXX.XXX’,
1 => ‘XXX.XXX.XXX.XXX’,
2 => ‘XXX.XXX.XXX.XXX’,
3 => ‘XXX.XXX.XXX.XXX’,
4 => ‘XXX.XXX.XXX.XXX’,
5 => ‘XXX.XXX.XXX.XXX’,
6 => ‘ichwillinmeinecloud.net’,
),

Die XXX Stehen fĂŒr IPÂŽs in meinem fall Öffentliche und VPN :wink:
Achte auf die zahlen davor und die beistriche am ende
Wo IPÂŽs stehen oder die DNS links die reihenfolge ist egal

1 Like

Hallo,

vielen Dank fĂŒr deine Antwort.

Genau diese Zeilen in der config.php habe ich ausgefĂŒllt, mit IP-Adresse, Webadresse etc.

Leider hat es bisher keinen Einfluss auf das Verhalten im Browser gehabt.

‘trusted_domains’ =>

array (

0 => ‘localhost’,

1 => ‘62.113.246.167’,

2 => ‘andre-wagner-photography.de’,

),

Was kann ich sonst noch prĂŒfen, woran es liegen könnte?

Das Setup-Interface von Nextcloud ist soweit problemlos durchgelaufen.

Danke fĂŒr einen Hinweis


Hallo ,

ich geh mal davon aus der link ist echt dann aber hast du im Webserver einen fehler

auf
http://andre-wagner-photography.de/index.php/login

Kommt

404 Not Found

und auf
https://andre-wagner-photography.de/index.php/login
kommt

Bad Request (400)

dein nginx 1.14.0 auf dem Ubuntu ist falsch eingestellt :wink:

Hallo,

dann wird es haarig.

Damit kenne ich mich nicht wirklich aus. Hilfst du mir dabei weiter?

Bei systemctl status nginx.service bekomme ich folgende Meldung:

nginx.service - A high performance web server and a reverse proxy server

Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)

Drop-In: /etc/systemd/system/nginx.service.d

└─override.conf

Active: active (running) since Tue 2020-03-31 23:34:08 CEST; 10s ago

Docs: man:nginx(8)

Process: 32026 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=0/SUCCESS)

Process: 32024 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=0/SUCCESS)

Main PID: 32030 (nginx)

Tasks: 2 (limit: 4915)

CGroup: /system.slice/nginx.service

       ├─32030 nginx: master process /usr/sbin/nginx -g daemon on; master_process on;

└─32032 nginx: worker process

Mar 31 23:34:08 myserver systemd[1]: Starting A high performance web server and a reverse proxy server


Mar 31 23:34:08 myserver systemd[1]: nginx.service: Failed to parse PID from file /run/nginx.pid: Invalid argument

Mar 31 23:34:08 myserver systemd[1]: Started A high performance web server and a reverse proxy server.

Hilft das weiter?

Hallo, :sweat_smile: mit nginx kenne ich mich jetzt nicht so aus

Apache am laufen :wink:

aber wir können ja mal die conf mit anderen vergleichen

wenn die info noch stimmt solltest du in “/etc/nginx/sites-available/” die conf finden Poste mal alle die du da findest :wink:

Also,

bei nginx bin ich jetzt auch nicht bewandert. Bin halt mit Apache groß geworden.
Aber egal ob nginx oder Apache: Auf Port 80 wĂŒrde ich immer ein 301-Redirect auf den Port 443 setzen.
Das notwendige SSL-Zertifikat gibt es z. B. kostenlos bei “letsencrypt”.
Hier ist der Ansatz: Erstmal einen funktionierenden Web-Server aufsetzen.
Der nÀchste Schritt ist dann Nextcloud.

naja an dem liegt es im moment nicht :grin:
wenn man auf
http://andre-wagner-photography.de

geht wird man auf
http://andre-wagner-photography.de/index.php/login
weitergeleitet

Deinem

stimme ich zu aber erst mal sollte das teil ordentlich erreicht werden :wink:

und so wie ich das sehen hat sich da wohl ein fehler eingeschlichen die cloud ist auch da (Weiterleitung auf /index.php/login und die Meldung

) aber es wird nicht Ordentlicht beantwortet

Entweder falsche rechte oder falsche einstellungen in der nginx conf wĂŒrde ich jetzt mal sagen mit den infos

mal sehen was wir noch finden :wink:

Doch daran liegt es.
Sonst wĂŒrde ich keine 404-Fehler (not found) vom nginx Server erhalten.
Irgendwas stimmt mit der Weiterleitung nicht.

Hallo,

ich finde dort nachfolgende conf-Dateien:

-rw-r–r-- 1 root root 556 Mar 21 20:55 autoconfig.andre-wagner-photography.de.conf

-rw-r–r-- 1 root root 2280 Mar 21 20:55 mail.andre-wagner-photography.de.conf

-rw-r–r-- 1 root root 437 Mar 30 21:06 example

-rw-r–r-- 1 root root 2517 Mar 31 02:38 default

dann nehmen wir uns die mal aufs korn was steht da drinn :smiley: ?

Hallo,

ich habe sowohl einen Apache und nginx Webserver parallel laufen.

Mein Mailserver dort lĂ€uft nginx ich habe Modoboa verwendet. Ich bin davon ausgegangen, dass nginx Voraussetzung fĂŒr Nextcloud ist. Apache lĂ€uft:

apache2.service - The Apache HTTP Server

Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)

Drop-In: /lib/systemd/system/apache2.service.d

└─apache2-systemd.conf

Active: active (running) since Tue 2020-03-31 01:24:33 CEST; 23h ago

Process: 25171 ExecReload=/usr/sbin/apachectl graceful (code=exited, status=0/SUCCESS)

Main PID: 14357 (apache2)

Tasks: 6 (limit: 4915)

CGroup: /system.slice/apache2.service

       ├─14357 /usr/sbin/apache2 -k start

       ├─25177 /usr/sbin/apache2 -k start

       ├─25178 /usr/sbin/apache2 -k start

       ├─25179 /usr/sbin/apache2 -k start

       ├─25180 /usr/sbin/apache2 -k start

└─25181 /usr/sbin/apache2 -k start

Mar 31 01:24:33 myserver systemd[1]: Starting The Apache HTTP Server


Mar 31 01:24:33 myserver systemd[1]: Started The Apache HTTP Server.

Apr 01 01:19:06 myserver systemd[1]: Reloading The Apache HTTP Server.

Apr 01 01:19:07 myserver systemd[1]: Reloaded The Apache HTTP Server.

image001.jpg

Finde ich klasse, dass du mir hilfst


Es gibt noch viel zu lernen, wie ich gerade festelle
 :grin:

Gerne gebe ich dir die Infos, die du brauchst.

Keine gute Idee. Entweder oder.
Wenn alles Andere ĂŒber nginx lĂ€uft, dann bitte Apache deinstallieren.
nginx und Apache “prĂŒgeln” sich um die Ports :wink:

1 Like

Da hast du Volkommen recht und das kann auch der Grund sein warum das gerade so ablÀuft :rofl:

naja also wenn nur Nextcloud auf dem Apache lÀuft Dann mach den Apache wieder weg und mach das hier

dann sollte danach alles laufen :wink:

aber pass auf das die Wege zu deinem ssl-zertifikaten auch angepasst werden in nginx :wink:

In der autoconfig.andre-wagner-photography.de.conf steht das:

This file was automatically installed on 2020-03-21T20:55:17.297962

upstream automx {

server unix:/run/uwsgi/app/automx_instance/socket fail_timeout=0;

}

server {

listen 80;

listen [::]:80;

server_name autoconfig.andre-wagner-photography.de;

root /srv/automx/instance;

access_log /var/log/nginx/autoconfig.andre-wagner-photography.de-access.log;

error_log /var/log/nginx/autoconfig.andre-wagner-photography.de-error.log;

location /mail/config-v1.1.xml {

include uwsgi_params;

uwsgi_pass automx;

}

}

Lach ist schon gut das gehört dann zu deinem Mail server nehme ich an.

Lösche den Apache mal Also nicht die cloud oder anderes nur den Apache

Mit dem sudo apt-get purge apache2 apache2-utils

danach mal eine Conf beim nginx
also Nano /etc/nginx/sites-available/nextcloud.conf

Und mach es nach der anleitung

achte auf die Persönlichen einstellungen Wie Pfade zur Nextcloud (//var/www/Nextcloud) server_name und root /
aber auch die wege zu den ssl-zertifikaten dann sollte er danach richtig starten

I do not know much about nginx:

But this will not work.

Warum schreibe ich hier eigentlich in Engisch?
Aber ĂŒberall steht in deiner Konfiguration “autoconfig
” Nicht gut.
Wenn, dann ist der Server Name: “andre-wagner-photography.de”

Ich glaube, ich setze das System noch einmal neu auf und mache dann alles ĂŒber den Apache (Nextcloud, Mailserver und Joomla).

Ist vielleicht einfacher fĂŒr einen AnfĂ€nger wie mich
 :wink:

Ich melde mich dann noch mal bei Problemen mit Nexcloud.

1 Like