Android Talk not working with loudspeaker when video on

Long term Nextcloud user here at wit’s end with ‘family’ Nextcloud v22.x setup and Talk 12 backend.

Android Talk does not work with external loudspeaker with new Android 11 phone. We have been using Nextcloud talk on Android for years to 1:1 video conference without issues or at least issues I could resolve. Until recently one member of family decided to upgrade their phone to an Android 11 model.

Let me explain my journey to resolve to date:

Initially not even the microphone worked after install of the Talk App, but talking user through to Permissions and adding Microphone permission to Talk solved this problem. However there appears to be no permission in Android to set for the use of the external loudspeaker on the mobile phone regardless whether video is on or off.

Their Skype works fine and activates the external loudspeaker when used with video. Normal phone calls go through internal/ear speaker. So you can imagine my frustration that Android Nextcloud Talk doesn’t work like Skype out of the box and activates external loudspeaker upon receiving video call. It does work on the internal/ear speaker BTW

After searching a lot on the internet I was unable to find a possible solution short of going into developer mode and activating all kinds of magic to activate an external loudspeaker switch icon. This reasonably can’t be explained to simple users remotely and I’m not even sure it would work without additional supporting coding in Talk. Haven’t been able to try not having an Android 11 mobile myself (yet).

Ideally Android Talk would automatically turn on loudspeaker on Android 11 when on a video call like Skype apparently does. It works on Talk too on older Android version I know off e.g. 6 and 7.

Perhaps it is a feature request, or a bug in code which broke Talk with Android 11?
Hope someone has some insights or tips on how to resolve or point me to the user error at play, doubt I’m the only one encountering this nuisance.

Bump, anyone a clue for me on the above please?

Just found that this has been worked on (thanks!) and recently got a solution in the form of extra options to select audio-out channel. Brilliant. It is in Release v13.1 which hasn’t been released yet though. Looking forward to next release.