Android Nextcloud Talk

I’m always fascinated with the lack of response on a forum that is meant to be a community forum. :expressionless:

I recently performed a manual upgrade of Nextcloud (inside linuxserver docker) from 21.* to 23.07.
I have an unusual issue now, where Nextcloud Talk 14.1.0 will not allow me to connect to the server with my usual account. I’ve deleted and re-issued an app password from my security settings, however when I attempt to create the account;

I type in the server address:
I specify an app password and enter the username in lower case and the password.
Select “Grant Access”.

It automatically reverts back to entering the server address again.
Here is the unusual bit:
If I create a new user account on the server and set up an app password, it works immediately.
It also worked for the existing admin account.

On my Android phone:
I’ve cleared the cache and the data for Nextcloud Talk.
I’ve deleted and re-installed the app.

This does not resolve the issue.
There are also no logs that demonstrate there is an issue.

I’m running linuxserver docker behind an nginx proxy.
My config.php:

$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => '',
    'port' => '6379',
  'datadirectory' => '/data',
  'instanceid' => '***********',
  'passwordsalt' => '********************',
  'secret' => '************************',
  'trusted_domains' =>
  array (
    0 => '',
    1 => 'nextcloud.************.com',
    2 => 'documents.************.com',
  'trusted_proxies' =>
  array (
    0 => '',
    1 => '',
  'dbtype' => 'mysql',
  'version' => '',
  'overwritehost' => 'nextcloud.************.com',
  'overwrite.cli.url' => 'https://nextcloud.************.com',
  'overwriteprotocol' => '',
  'overwritewebroot' => '/',
  'dbname' => 'nextcloud',
  'dbhost' => '',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextycloud',
  'dbpassword' => '***********',
  'installed' => true,
  'twofactor_enforced' => 'false',
  'twofactor_enforced_groups' =>
  array (
  'htaccess.RewriteBase' => '/',
  'twofactor_enforced_excluded_groups' =>
  array (
    0 => '***********',

I re-iterate, there is no issue with new accounts, etc. I would assume it may be an issue where the account details are not removed from Android. However, I’ve no idea where to look. The Talk folder is deleted with the app.
I’ve looked at other topics where

'overwriteprotocol' => 'https',

is the answer, however https is handled by my reverse proxy and its http from proxy to server. Indeed, this has not been a problem before or for new accounts and I’ve tried this, without a result.

Help would be appreciated.

And I am always fascinated by how ppl get creative in unneccessary and unwanted doubling of some posting from the forum.

Trying to keep this forum as sane as possible, I’m closing this threat because there’s nothing new in it.

If you like to comment or push the original posting, feel free doing so by just commenting there.

And please accept that almost all helpers here on the forum are volunteers and thus you don’t have any guarantee of being helped - the so-called price of using community-software for free.

This post has been re-opened, as its a different issue to the Grant Access issue that other users are having with Grant Access.
Its not related to this issue:
Android Client 3.19.1 - Grant Access Issue - What I’ve Tried [fixed]

Its also not related to this issue, where the username capitalisation needs to be altered.
Nextcloud Talk on android jumps back to “Server address” screen after “Grant Access” is pressed

Windows client works fine (latest version).
Nextcloud App from the Play store work fine.
Importantly, I can add other accounts to my Talk app from the Play store that are either new or existing, but were not previously added to the Talk app before.

It must be a bug in the Talk App. I’ve cleared cache and data, but this does not resolve the issue.
One method may be to create a new account, add that account to the Talk forums and remove the original account and transfer all data over as well. Finally, deleting the account and being done with it.

However, Nextcloud is a mature eco-system and this should be resolvable.