Android client won't auto-upload photos

Hello. I recently got an Android phone and I’ve installed the Nextcloud app on it.

I’ve tried to configure it to auto-upload photos but when I check the uploads menu and it says there’s a “permission error” or whatever it’s called in english (I’m Swedish). I’ve tried to configure it to upload the photos to the Nextcloud photos folder.

I wish I could provide more info but I’m brand new to android phones so I’m not sure how to take screencaps. I’m still learning things here.

I hope you can help.

Hello,

same here, before 3.18 version it was working like a charm, after the android update to 3.18, i got a system request to grant sharing access, i accepted.
then all the auto uploads fail with “you don’t have the permission to upload”.

please help

Does the server have a valis SSL-certificate?
Are the owner-group settings in the data folder correct?
Did you find any problem related log entries in nextcloud.log (Nextcloud data folder or in /var/log/…) and the webserver’s log on the server?

Do you use “blanks” in your login credentials? - You never should do that.

I use version 3.18.0 without any problem.

I’m not sure how to check if the SSL certificate is valid. I’m pretty new to this. I’m also not sure how to check the owner-group settings.

On the logs I’m finding a bunch of errors but I’m not sure what they mean.

I have a log file in this link if you want to check. I don’t understand it too well, myself. I’m not too technical.

I’m sorry of the information I’m providing is insufficient.

i got valid certs
it may be an owner-group problem, i install php8 for test purpose and the system change my configured php-cli from php7.4 to 8 …
thanx for the advise i should search in that way.
I keep the post updated

I guess, that PHP 8 is the problem. You can find several threads in this forum about problems with Nextcloud and PHP 8.

ok, i found out the problem … it was the permission of mounted volume, it didn’t match with the user of the php socket

1 Like

How do I fix that? If that’s what the problem is for me. I’m not sure.