Android client fails immediately on new phone

My nextcloud works fine, i.e. the web interface works in a browser and the client (1.4.2) on my old phone, but on the new phone (a OnePlus 5, running OxygenOS 4.5.5 which is based on android 7.1.1) that I got last week, the client (also 1.4.2) just flashes a white screen and then closes. Until I upgraded it yesterday morning (to 20170713, I have just tried upgrading to 20170718) the dev version worked, and since then that has behaved similarly, I do see a glimpse of the list of files though. I have enabled regular backup of contacts, and those uploads fail, and when I get a notification about that, and touch that I get into the app on the list of recent upload attempts, from there I can go to e.g. settings (didn’t perform thorough testing), but if I try to go the list of files, the app exits.

Synchronisation of calendars/contacts/sms’es (I use DavDroid for calendars/contacts and NextCloud SMS for sms’es) works fine.

What can I do to get access to my nextcloud from my phone again?

I’ve installed both version of the client from f-droid, but if I search for nextcloud in google play, it finds the version I’ve installed.

Can you give us a logcat while the app crashs?

I know this is not the easiest, but I doubt that we can get the crash reason with an other approach…

Will a bugreport offer the logs you need also?

Because alternatively, a selection of logs can be gotten with a bug report and it’s much easier to get :slight_smile:

Settings > About
Tap Build number 7 times
Tap back into Settings
Tap Developer options
Tap Take bug report
Select Interactive to take a screenshot, or full to get more detail. When ready, it’ll appear in the notification area and you can share it (or upload to your NC :))

The logcat is almost a megabyte, but:

Thank you for your bugreport.
According to your logcat, this bug is known and already fixed in latest dev version and will be fixed in next official release.
If you want to use 1.4.2 you can try to switch the device to english, then start the app, enter the credentials and then switch back to your native language.

Do I understand you correctly that your dev version does not work? I see there an exception for dev version, but it the app crashing?

You can also remove your logcat as I saved it and I am not 100% it there are not some private data, like urls, in it.

Logcat removed.

It’s probably been a week since I bothered trying the non-dev version. I.e. that logcat only shows attempts at starting the dev version.
And yes the dev version crashes for me. (I didn’t report this when the problem was only with the released version, as I hoped the issue would be fixed in the next version).

Temporarily changing language to english, did indeed make 1.4.2 start, and after entering credentials I can see the files on my nextcloud! And it still works after changing back to danish! Thanks.

Both while the language was set to english, and after setting it back to danish, I’ve also tried to start the dev version, with the same result as before, the list of files/directories flashes and the the app crashes. I’ve made a short screen capture video, showing it, it’s not really interesting, but:
(having a working nextcloud app made uploading that really simple)


I know it is not perfect, but can you try to install the latest dev version after removing it?
Which dev version do you use? Fdroid or
For some reasons it tries to access the wrong account credentials, those from your sms app.

I am using 20170718 from f-droid. And removing it and reinstalling it (still through f-droid) gave me a version that works.

Glad to hear.
The upgrade process or the official app should have no problems. I guess there were just some intermediates/leftovers on your device.