Android auto-upload from SD card


#1

Is it a known issue that auto-upload doesn’t work from an SD card? I just got a Galaxy S9+, inserted a 64 GB SD card, and configured the camera to take pictures to the card. Then I turned on auto-upload in the Nextcloud app and it just won’t auto-upload anything. The pictures appear in the preview area of the auto-upload pane, but they never make their way to “uploads” and consequently they don’t get uploaded.

Using “force rescan” in the uploads pane doesn’t seem to do anything either.


#2

It should work, but I don’t have access to S9+ unfortunately :frowning:


#3

:confused:

Well, I got it “working” by setting up an app called FolderSync to upload files in my Camera folder to a temporary “staging” directory on Nextcloud, and a cronjob to move and rename files in that staging directory (because if I set up FolderSync to upload directly to the destination directory it seemed to have a habit of deleting the entire destination directory full of my photos).


#4

What Android version is this?


#5

Android version 8.0.0
Samsung Experience version 9.0
Kernel version 4.9.65-13087505 (Sun Feb 25 18:46:03 KST 2018)
Build number R16NW.G965U1UEU1ARBG
Android security patch level February 1, 2018

Nextcloud app version 3.0.3


#6

Same here. Photo Upload don’t work instant and photos are saved in SDcard. Photos will upload sometimes even 2 days after.
Android version 8.0.0
Samsung Experience version 9.0
Kernel version 4.4.13-12993647
Build number R16NW
Android security patch level February 1, 2018

Nextcloud app version 3.1.0 RC1


#7

Photos are not supposed to upload instantly. As long as they upload it’s fine :slight_smile:


#8

Same issue here, with a Galaxy S9+ on Android 8.0. Setting auto-upload to pull from a phone storage folder works, but if the location (even a custom folder location) is located on the SDcard, it never uploads (not after 2 days, not after 2 weeks, never).


#9

i wonder if its only a glitch referring to samsung s9+ - since it works flawlessly for me, using nokia 5, android 8.1 (SD-card formatted as internal)


#10

The Galaxy S9 can’t mount an SD card as internal storage. It’s only mountable as external storage.


#11

so it really could be b/c of samsungOS.


#12

It’s possible, but I have another app (FolderSync) that has absolutely no problems detecting pictures being written to the SD card, so it’s not like it’s impossible for Nextcloud to work with it.


#13

I am having the same issue with my S9.
Mine uploads some photos but not others. very strange.

In my May folder on my nextcloud server it had 41 photos. After I manually copied the missing files it had 134 photos.
I couldn’t really see a pattern as to why photo got picked and what photo didn’t get picked. Photo that were taken within a few seconds of each other. One would get picked and the other wouldn’t.

Any ideas how to troubleshoot this?


#14

I have the exact same problem - S9+ - using latest nextcloud server and app

nothing wrong with other devices using same instance for uploading. but on my S9+ some photos and videos wont upload automatically. Yet most of them will. i have camera storage set to SD card and it is encrypted. Dont know if the encryption has anything to do with it though.


#15

@Catsrules, @lime333

i am sure you have read the postings above yours… and so it should have gotten clear that this error seems to be a samsungOS-error, only. so either wait until @mario go the time to code something into the app or until samsung fixed this issue (which they might not be aware of if you don’t tell them)

rock on and cheers :wink:
jimmy


#16

Same here on Galaxy S9.
Autoupload doesn’t work !


#17

Can you folks disable/ignore battery optimizations for the Nextcloud app first and then tell me if it works/doesn’t work? :slight_smile:


#18

Done, still no auto upload ! (but great idea :stuck_out_tongue: )


#19

I have a workaround for this on the Galaxy S9/S9+. Under Camera, set your photos and videos to save to Phone Storage (normal). Next, go to your phone Settings -> Apps, and find Nextcloud. Click the Storage link, and change the storage to SD card. Now, go to your Nextcloud app, InstantUpload, and change the settings for your Camera upload folder to “After Upload -> Move to app folder”.

Now your photos and videos will upload successfully, and you’ll still have access to them directly in your phone’s Gallery app, but they’ll end up being stored on the SD card through a sideways route.


#20

Hmm mine still is acting the same way even with the photos being on the Phone Storage.

Edit
Never mind false alarm I am just an idiot and had my WiFi Turned off for a few days without realizing it.

Edit2.
I tried to post about this problem on the Samsung developers forum and it was deleted a few days later. :frowning: Not sure why maybe it just auto deletes posts if they aren’t active within a few days.