Android Apps cant find my Server anymore

Since today the nc android app displays “server not available” when using mobile data.

Same problem on two different android phones.

I can still reach the server with browsers (using mobile data).

The notes app’s log says “Unable to resolve host”.

Any ideas?

Things I’ve tried:

  • reboot Phone, Router, nc-server
  • checked nginx service
  • checked port forwarding
  • removed and re-registered my account inside the nextcloud app and the notes app
  • checked fail2ban jails

Browsers that are off-network?

This is indicating a DNS resolution issue. Can the phones correctly resolve the hostname while on mobile data?

1 Like

Thanks for your reply!

Using mobile data, my android phone can reach my nextcloud instance using a web browser but the apps say ‘server unavailable’.

The browsers actual show the online version (no cached offline version or pwa).

Is the app set to use the same server URL you put in the browser?

1 Like

Yes and this worked for months (or years?)
I don’t know what changed…

Things I’ve tried:

  • reboot Phone, Router, nc-server
  • checked nginx service
  • checked port forwarding

Try going to https://scan.nextcloud.com and/or https://www.ssllabs.com/ssltest and running their tests on your server. If the test works, this validates your hostname, port forwarding, and certificate.

1 Like

@tompson
Maybe you can add another account from your server. Do you get the same message while access a new account?

1 Like

scan.nextcloud.com → A Rating (displays wrong/outdated server version)
ssllabs.com → A+ Rating

I don’t think that the problem is related to users.
Using 2 different users lead to the same problem.

Anyway I checked your suggestion: when I want to login new, additional user in the nextcloud app, I get cloud not find host before I type in the login credentials.

Maybe you can test with another Nextcloud. You can get a 60 minutes free Nextcloud at https://try.nextcloud.com. Unfortunately, you now have to register there with a (spam) email address.

1 Like

Good idea!
With the trial the android apps work.

Now I checked ufw and iptables and ist seems to be fine…

1 Like

Okay seems like it’s a problem with my dns provider not with the apps.

1 Like

I tested it again with the second android phone. It’s working now but the first phones app can’t reach the server.

Is it possible top view or generate logs in the nextcloud app?

I can’t speak to log generation, but since this seems DNS-related: browser apps can ignore the device’s DNS settings in favor of their own, which might explain why the browser works and apps don’t. Comparing the two might get you your answer.
I’d look extra hard at “Secure DNS” if it’s turned on - if the DNS server you’ve otherwise configured doesn’t support DNS-over-TLS (DoT), this setting might override your settings and use Google instead.

2 Likes

tl;dr problem solved on it’s own.

Yesterday most other apps on my android didn’t have internet connection using mobile data. Today the everything is fine. The problem seems to be solved. I did not do any additional steps to fix it.

Thanky everyone for helping out with this!!!