Android App stuck on Testing connection

Nextcloud version (eg, 20.0.5): 22.2.0
Operating system and version (eg, Ubuntu 20.04): Debian 10
Apache or nginx version (eg, Apache 2.4.25): Nginx 1.14.2
PHP version (eg, 7.4): 8.0.12

The issue you are facing: When trying to use the Nextcloud Sync app on Android 12, it gets stuck at “Testing Connection”. I have this running with a Lets Encrypt SSL cert, the server has both an IPv4 and IPv6 address, and has worked in the past. When I check /var/log/nginx/access.log while trying to connect, it shows nothing other than my Windows connections. However, if I open up Chrome or Firefox on my Android 12 device, it will connect to the web page just fine and allow me to login, and I see that reflected in the access log.

I updated my phone to Android 12 around the same time I updated my Nextcloud instance to 22.2.0, so I cannot say for certain that one or the other is the culprit. It worked before upgrading these 2, and has continued to work just fine on Windows, Linux as well as in the browser without issue. I also do not have any apps on the device that would block connections, and have tried this with or without WiFi, and get the same result.

The issue was noticed when no files would update or sync on the device, so i decided to clear all data and set it up again, and it will not connect. I can, however, get the app to show that no instance could be found by typing in some random URL, and it will say “Could not find host”, so its able to find that my instance is a host.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Hit “Log In” on the App
  2. Enter server URL or scan the QR code from the Admin section

The output of your Nextcloud log in Admin > Logging:

Only information (with every box checked) is clam not checking files that were deleted while scanning, the nextcloud log being moved, and nextcloud news updates.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

The output of your Apache/nginx/system log in /var/log/____:

Nothing there for access.