Android app can't connect

Hi all,

I’m currently running nextcloud on my server, currently at v12.0.3.

On my Android phone, I have been running the nextcloud client, currently at v2.0.0.

This setup was working well for at least a year. For some reason, it broke several days ago. The app can no longer connect with my server. I have tried disabling the VPN, rebooting the phone, deleting my profile in the app. When I try to enter a new profile, it can’t reach my server. Nothing helps.

On the server, I tail /var/log/nextcloud.log, but I don’t see any useful information.

On the phone, I can connect to my nextcloud installation in a web browser, so I know the network connection exists.

On my laptop running Linux Mint, the nextcloud client continues to work fine.

I urgently need to get the phone app working again. Please help me figure out went wrong here. Thank you.

Depending on which web server you’re using, I would be watching tail -f /var/log/apache2/access.log or /var/log/nginx/access.log while you attempt to connect with the app, and see if it’s hitting the web server.
Just throwing this out there, double check that the app is not blocked by a firewall app that might be installed. I’ve done that plenty of times and forgotten to allow network access to apps.

@cbrace Can you send a PM with the server address (if available on the internet) to @tobiasKaminsky and me, then we can have a look if we can connect with the app while I’d also say it has something to do with the server e.g. brute force table of Nextcloud itself. So my advice before all that would be to check Nextcloud’s brute force table because that one would raise the response time above the clients http response timeout limit.

Thank you, I took a look but I don’t see anything that helps me

See PM, thanks.

In that case apparently it’s not hitting the server, so that indicates that the problem is with the network connection or something else on the device end.

Indeed that’s a pretty good tell the device isn’t accessing the Apache instance at all, which would suggest it’s a device issue more than server in this case.

I think I’ve narrowed down the problem. Disabling WiFi on the phone, I could once again connect to my server via the 4G network connection.

Reactivating WiFi it broke it again.

The only change I can think of is that my ISP recently migrated my VDSL2 connection to IPv6. Up to now I have encountered no issues with it.

My nextcloud server has an IP6 address assigned. I can ping it with traceroute6.

On my phone I can connect to my server through the WiFi connection in a web browser. But the nextcloud client doesn’t seem to be able to. Could IPv6 be interfering with the client in any way?

If the server doesn’t have a ipv4 than that is likely the issue since the client only supports ipv4 :frowning:

I experienced something similar (if you can connect without WiFi and not with wifi) Seems that some old connection is being cached, because (looking in logs), it tries to connect to gateway of my phone company (even though it is connected to wifi!) Only solution I found was to reboot phone. I cannot repro this reliable enough though.

Same here. I can connect to the server and the login window shows up. But when i try to login, nothing works and the app redirects to the window with the server-adress.


This text will be hidden

We just released 3.0.0RC1 which ships a fix for ipv6 so you might want to give it a try since that might fix your issues in case of it being an ipv6 issue.


Sorry for the slight delay in following this up. I can confirm that v3 of Android apps solves the issue I was having. It did indeed appear to be IPv6 related.
Many thanks for to you all for all the good work.

1 Like

Glad to read that 3.0.0 solved the issue for you :slight_smile:

Kudos to @mario for adding ipv6 support :tada: