Android app can not connect


#1

I have Nextcloud 13.0.2 installed on Ubuntu 16.04 LTS
I can access it from different phones, tablets, LAN & WAN.
The only device I can’t access it is Xiaomi Mi A1 global version with Android 8.0.0
When I try to access server I get message “Connection could not be established”
I can access server from the browser when connected to the WiFi and enter server IP address.
If I use server dynamic DNS address I can’t access it and error message is: “Connection timed out”
This works on any other device I have which tells me that port forwarding and dynamic DNS are working properly.

Any advice how to solve this will be greatly appreciated.

Thank you


#2

Hello Community,

I seem to have the same issue.

My Nextcloud server is only used inside my WLAN and if I try to connect from any Android device to the https instance of my Nextcloud installation, the Nextcloud app says “Connection could not be established”.

The http access works fine.

Removal and reinstallation of the app didn’t help (incl. deleting any data and account during removal).

Any other Android client-app I use (DAVdroid, Tasks, Nextcloud Notes) works fine.

Accessing my Nextcloud using a browser is possible and also the Linux desktop client doesn’t make any troubles.

Nearly half a year ago I installed Nextcloud on my Synology DS216j and since the first successful start-up I haven’t had any problems.

Today I updated to Nextcloud 13.0.2 without any problems but that didn’t solve the problems with the Android app.

Unfortunately I don’t exactly know, when this strange app behaviour appeared the first time.

I recognised that the app doesn’t ask for confirmation of my self signed SSL certificate as it did while setting up the Android apps the first time.

I would be very glad if anyone could help.

Thx in advance and kind regards

Lanzi


#3

What kind of certificates are you using? Self-signed or Let’s Encrypt?


#4

I am not using any SSL certificates.
Is Android 8.0 looking for SSL certificates as any device with previous android versions can connect without any issues.


#5

I use a self signed certificate.

Don’t actually know if the problem is related to Android or Nextcloud. :frowning:


#6

My Problem is solved!

The phenomenon seems to be caused by an outdated (duplicate) DNS record in my router (AVM FRITZ!Box).

Usually I use a USB WiFi dongle with my NAS with a fixed IP address but while trying to get all my systems back to work after a blackout I connected it using the wired connection.

Therefore it received a second IP address by DHCP and my router didn’t drop this entry after unplugging the wired connection.

Requesting the FQDN within the Nextcloud App the router replied two IP addresses and the App simply used the wrong one.

After resetting my router to factory defaults everything works fine again.

Thanx a lot so far and please carry on solving TE7’s problem!


#7

Did you try connecting your Nextcloud instance by IP address with your Android App?

If not, try using the IP and tell us what happened.


#8

When I used IP address I got error: The server took too long to respond.


#9

This response sounds like a protocol error.

Did you try HTTP or HTTPS or both?


#10

Application defaults to HTTPS and it can’t be changed - see pictue in the first post.
I have forwarded external ports 80 and 443 to internal.
As I mentioned it all works OK on other phones, tablet, computer. Even from this phone I can access Nextcloud server by typing address in web browser. Only app does’t want to connect for some reson.


#11

Oh well, the App may use HTTP if you not specify HTTPS.

Just give this URL format a try:

https://www.example.com:443/nextcloud


#12

Thank you for the tip and help. :+1:
I actually found another Nextcloud test site.

It works and I’ll have to check my router setup and try to solve the puzzle why all other devices can conenct without any issues.