AMD support for community document server?

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version 18.0.1:
Operating system and version FreeNAS-11.3-RELEASE (using FreeBSD 11.3):
Apache 2.4.25:
PHP version 7.2.27:
AMD Ryzen 3 1200 Quad-Core Processor

The issue you are facing:
After a fresh nextcloudinstall, installing community server and installing onlyoffice i get the following message when trying to open any document.
Community document server is not supported for this instance, please setup and configure an external document server. only linux based servers are supported

Is this the first time you’ve seen this error? Y:

Steps to replicate it:

  1. Install Nextcloud
  2. Install community document server
  3. install onlyoffice
  4. Create a document

Is there no support for AMD architecture in community server and onlyoffice?

The output of your Nextcloud log in Admin > Logging:

OCA\DocumentServer\Document\DocumentConversionException: sh: ./x2t: Exec format error
/usr/local/www/nextcloud/apps/documentserver_community/lib/Document/ConverterBinary.php - line 72:


/usr/local/www/nextcloud/apps/documentserver_community/lib/SetupCheck.php - line 34:


/usr/local/www/nextcloud/apps/documentserver_community/lib/Controller/StaticController.php - line 89:


/usr/local/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 170:


/usr/local/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 99:

OC\AppFramework\Http\Dispatcher->executeController(OCA\Document ... {}, "webApps")

/usr/local/www/nextcloud/lib/private/AppFramework/App.php - line 125:

OC\AppFramework\Http\Dispatcher->dispatch(OCA\Document ... {}, "webApps")

/usr/local/www/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php - line 47:

OC\AppFramework\App::main("OCA\\Docume ... r", "webApps", OC\AppFramew ... {}, { path: "app ... "})


OC\AppFramework\Routing\RouteActionHandler->__invoke({ path: "app ... "})

/usr/local/www/nextcloud/lib/private/Route/Router.php - line 299:

call_user_func(OC\AppFramew ... {}, { path: "app ... "})

/usr/local/www/nextcloud/lib/base.php - line 1008:

OC\Route\Router->match("/apps/docum ... s")

/usr/local/www/nextcloud/index.php - line 38:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

The output of your Apache/nginx/system log in /var/log/____:

Your posting does not mention any message regarding Intel/AMD.
AFAIK the base for using document server are x86/64 based systems

BSD ist not linux.

Not sure if this is the cause…

1 Like

Hey @kristoffer99,
did you found a solution?
I have nearly the same configuration (Freebsd12.1 and NC18.0.3) and have the same error with onlyoffice and DCS.

Thanks for your feedback,

update: I found, on a german blog some info concerning this error ( point 12 ((nearly last point)) ). It says that if you got this error, it’s because you have an ARM CPU. Thus, could be, as @rakekniven says because it’s no linux… let’s get a look at our onlyoffice friends :slight_smile:

maybe he meant ARM? so then it’s known that community document server won’t run on an ARM-cpu.

@JimmyKater: Indeed :slight_smile:
FreeBSD is no ARM but it’s also no Linux but Unix based…
Just found out there’s also a issue opened on the DCS page:
But no solution yet…

Hopefully, an expert will hear our voice :)))
Thanks for the reply anyway :ok_hand:

thanks for the help, seems as FreeBSD is the problem

thanks for the help. looks as though it is the FreeBSD that is the problem

My bad, i mixed up some post I read about ARM with AMD. However it seems to be the FreeBSD that is the problem. Thanks anyway. I have not tried to solve it with any VM yet. I dont have that much of a need for this solution yet so Im hoping there will be a solution in the near future for FreeBSD as well

Hi @kristoffer99 and @JimmyKater
just to let you know that there is a solution but it’s a bit of a manual recipe…
in a few words, OnlyOffice Document Server has to be built on FreeBSD with the proper packages.
If you’re interested, the complete story/solution is here:

Note that the solution is not yet stable and therefore not yet merged.
I’ll give it a try when I find some time.

Have a good evening,

1 Like