Alpine Linux, You need to enable the File sharing App

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 24.03
Operating system and version (eg, Ubuntu 20.04): Alpine v3.16
Apache or nginx version (eg, Apache 2.4.25): lighttpd-1.4.64-r0
PHP version (eg, 7.4): php8-8.0.22-r0

Working in an lxc container
with haproxy frontend.

Everything seems to go well. I can install apps, i can add things to the calendar.

The issue you are facing:
I cannot enable Sharing.

When i go to Administration->Sharing i’ll get an warning ‘You need to enable the File sharing App’


I didn’t known there was a nextcloud-files_sharing alpine package.
apk add nextcloud-files_sharing got me on my way.

next i adjusted my passwd file so i could su to the nextcloud user
then i did php occ app:enable files_sharing in the /usr/share/webapps/nextcloud folder.
Then changed the passwd back to nologin

The End