"Allow upload" is missing for share by link. How to enable?

In my nextcloud install I do not see check boxes for public upload while I am sharing thru link.
In configurations it is enabled.

Also I do not see “Hide file listing”.

Nextcloud version: RC1
Operating system and version: Centos 7.1
Apache: 2.4
PHP version: 56