Allow for all external sharing to be disabled

I’m evaluating NextCloud for use in a completely internal intranet. No outside sharing is allowed, for security reasons. As such, no Twitter, Facebook, no federating, etc. Only sharing between users, or via link.

I’ve already managed to configure a docker instance to host nextcloud, talking to a caching openldap, backed by the company’s AD, and have 3300 users imported.

As a test, I tried to disable federatedfilesharing, but got the warning about it not being able to be disabled. I can work around that by editting core/shipped.json, to allow for the disabling, and the frontend appears to work.

I can understand why that might be in the alwaysEnabled option. But then why can’t I turn off those things for the frontend?

The class of users I have to support needs a trimmed down feature list, and federation is too complex.

Do you mean you tried to disable the federation-app? If so and this failed, you can disable the all federated-sharing-functions in settings->Admin->Sharing->FederatedCloudSharing

I see no such option, using Sharing is a top level menu under Admin, with no sub-level. Fyi, I have no disabled apps at all.

The target installation is sitting behind a rather restrictive outbound firewall; only approved servers are allowed. This means things like facebook, twitter, youtube, etc, are blocked. But I can see those options in Settings>Personal.

Any new feature, or feature that is available but non functional, has a high cost for training. This company has 1800 employees(give or take), with 10-20% turn-over per year. Training is a large cost. And that includes any supporting website that is installed. That is what is driving my desire to hide/disable functionality that wouldn’t even work in the target environment anyways.

I may just have to resolve to hiding things with css, where possible.

If you scroll down in the sharing menu, you will find to the headline “Federated Cloud Sharing” (tested for NC 12.0.0 & 11.0.4)

I agree with you. You should also evaluate the option to contribute to this project for two reasons:

  1. As a representative of 2k enterprise users you’ll probably come to the point, where standard functionality won’t meet your needs. Contribute yourself or pay somebody to do this job for you, helps the Nextcloud project to become an even better solution for enterprise users.
  2. Shape nextcloud to your needs is one idea behind open-source-philosophy. A major benefit based on this could be, that you can lower cost for user support & training etc. Ask yourself why you should spend money and/or resources on dealing with an unwanted functionality, if you can work on the root cause?

I don’t see that option. Perhaps cross-upgrading from owncloud 10 to nextcloud 12 disables that setting section?

As for changing the code, I’m quite capable. However, it’s best to ask the experts who have more experience, before going down a rabbit hole.

Then you disabled the Federation app, imho.


This section is between Sharing and Trusted servers.

I deleted my extracted download. Reextracted. Deleted my database. Reinstalled. I now see the section as you have pointed out.

During my investigations, I discovered core/shipped.json; it lists federatedfilesharing as alwaysEnabled. I modified that, to allow me to disable the app, which seemed to work. Perhaps some setting got confused during the process.

After I reinstalled everything, I attempted to do the same set of steps to make it break, and I couldn’t get it to break again.

Unchecking the options as you have said does remove the federation setting from the user’s personal page. But it still shows 5 social sharing options in the Version section; it’d be nice if each element had a uniquely identifiable class, but that’s another issue.

Social sharing is done via apps, this should disappear if you disable this app. But as you said it is a different issue, open a new topic if you still have a problem with that.