All clients stopped connecting to NC

Support intro

My best attempt to provide information. :slight_smile:
Middle of project ( 3 people working remotely (sharing data) from last months) on self hosted home server and it was working perfectly. Yesterday all of a sudden (in morning) all nextcloud client apps stopped working (unable to connect)

home server setup is simple (CENTOS 7 with CWP and NextCloud installed via softaculous)

I started digging… error was something like that
Screenshot-from-2021-02-10-11-30-10 — ImgBB

What i have already tried, using occ
rescan all files all users
remove nextcloud db ip blocks
remove server blocked ip

Also noticed then, i can’t connect via rclone (linux util) which previously i had tested and worked.
Also noticed then, next cloud is working from browser, but as soon as i log-in, top right area shows notice that Fobidden msg.

Also tried, each and every possible thing which i can, unable to solve.
Any ideas would be hugely appriciated, as i am hobbist linux user, setup small server at home for work and life was going good.
Hope to hear soon., thanks.

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version_: 19.1
Operating system _: centos 7
Apache or nginx version _: apache > php-fpm
PHP version _: 7.3

Is this the first time you’ve seen this error? (Y/N): YES

The output of your Nextcloud log in Admin > Logging:

[PHP] Error: Undefined index: from at /home/rainbow/public_html/nextcloud/apps/ojsxc/lib/stanzahandlers/iq.php#86

POST /nextcloud/index.php/apps/ojsxc/http-bind
from by admin at 2021-02-10T03:19:43+00:00

[PHP] Error: Undefined index: host at /home/rainbow/public_html/nextcloud/apps/ojsxc/lib/Controller/SettingsController.php#62

POST /nextcloud/index.php/apps/ojsxc/settings
from by admin at 2021-02-10T03:19:41+00:00

Try to disable the XMPP app using occ on the console. IF that fixes your problem, please create an issue ticket in the app specific repository:

Hi j-ed,

1- thanks for suggesting. app is disabled… same behaviour.

[root@cloud nextcloud]# sudo -u rainbow php occ app:list
The current PHP memory limit is below the recommended value of 512MB.

  • accessibility: 1.5.0
  • activity: 2.12.0
  • bruteforcesettings: 2.0.1
  • cloud_federation_api: 1.2.0
  • comments: 1.9.0
  • contactsinteraction: 1.0.0
  • dav: 1.15.0
  • federatedfilesharing: 1.9.0
  • federation: 1.9.0
  • files: 1.14.0
  • files_accesscontrol: 1.9.3
  • files_mindmap: 0.0.24
  • files_pdfviewer: 1.8.0
  • files_rightclick: 0.16.0
  • files_sharing: 1.11.0
  • files_trashbin: 1.9.0
  • files_versions: 1.12.0
  • files_videoplayer: 1.8.0
  • firstrunwizard: 2.8.0
  • logreader: 2.4.0
  • lookup_server_connector: 1.7.0
  • nextcloud_announcements: 1.8.0
  • notifications: 2.7.0
  • oauth2: 1.7.0
  • password_policy: 1.9.1
  • photos: 1.1.0
  • privacy: 1.3.0
  • provisioning_api: 1.9.0
  • recommendations: 0.7.0
  • serverinfo: 1.9.0
  • settings: 1.1.0
  • sharebymail: 1.9.0
  • support: 1.2.1
  • survey_client: 1.7.0
  • systemtags: 1.9.0
  • text: 3.0.1
  • theming: 1.10.0
  • twofactor_backupcodes: 1.8.0
  • updatenotification: 1.9.0
  • viewer: 1.3.0
  • workflowengine: 2.1.0
  • admin_audit
  • encryption
  • files_external
  • ojsxc
  • user_ldap


Due to the fact that there still seems to be code loaded from the jssxcapp directory, I would try to remove the app directory from the /home/rainbow/public_html/nextcloud/appsdirectory. Please make sure that you free all cashes afterwards.

i have removed app directory, restarted server. still same behavior.
Top right bar still showing “This Operation is forbidden”…

That seems to be a different story, because you opened this thread because all clients stopped connection to Nextcloud. If such a message is shown I would assume that logged-in successfully?

Can you please provide a screenshot of the message to get an idea where it might come from. What about error messages in the Nextcloud log file?

Hi j-ed,
just wanted to say thanks for support and help.
I have managed to sort this with help of CWP support team. Issue was with server , apache vhost template configuration. Fixing that solved both issues. ( desktop client connecting and web browser showing forbidden message )
Have a good day. regards,haseeb

1 Like