AIO Crashed and wont startup. same error when loading Linode backup or creating a new instance

okay, actually got soem more minutes and got a new instance under the subdomain

but when trying to visit it I get a SSL_ERROR_INTERNAL_ERROR_ALERT

oh wait, now its gone, was only a need of dns time

So under a new instance with a new subdomain it works (CAA Records untouched) so the problem is either somehwere with the linode or the sub-domain

can I change the domain of an existing nextcloud? would be the easiest for testing, to just change the subdomain to

Yes, see GitHub - nextcloud/all-in-one: Nextcloud AIO stands for Nextcloud All In One and provides easy deployment and maintenance with most features included in this one Nextcloud instance.

well, same thing, still a 502, means I will just setup a new Linode from scratch and Import a backup, that should work, right?

Yes, you need to transfer the borg archive from one to the other server first and import the backup then using the AIO interface but this should work.

okay, which way for transfering the borg archive would you suggest? ftp?

Yes, any server to server connection should work.

so from /mnt/backup/borg/ what should I get and move to the new server? or should I just copy everything over? xD

Just copy over the whole folder :+1:

okay, will do :+1:

backup loaded and restored, now I need to wait for the updated dns records xD

dns roled out, nxtcloud is usable again, thx for your help

All right, cool!

so in the end, we dont know exactly what the real problem was, but we were able to fix it, thx for your help


  • Reverse PROXY (Caddy) Wasn’t Working right.


  1. Create new Nextcloud
  2. Move over the /mnt/backup folder with scp
  3. Restore from backup

I think I am having a similar issue here. Just updated the containers, but am getting an HTTP 502 error.
After doing sudo docker container list -a, I noticed that my nextcloud-aio-apache container is unhealthy.
Upon further inspection, I get this from sudo docker logs nextcloud-aio-apache:

{“level”:“error”,“ts”:1672425457.2131164,“logger”:“http.log.error”,“msg”:“dial tcp connect: connection refused”,“request”:{“remote_ip”:“”,“remote_port”:“51784”,“proto”:“HTTP/2.0”,“method”:“GET”,“host”:“”,“uri”:“/”,“headers”:{“Accept-Encoding”:[“gzip, deflate, br”],“Sec-Ch-Ua-Platform”:[“"Windows"”],“User-Agent”:[“Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36”],“Sec-Fetch-Site”:[“none”],“Accept”:[“text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,/;q=0.8”],“Sec-Gpc”:[“1”],“Sec-Fetch-User”:[“?1”],“Cookie”:,“Sec-Fetch-Mode”:[“navigate”],“Sec-Fetch-Dest”:[“document”],“Sec-Ch-Ua”:[“"Not?A_Brand";v="8", "Chromium";v="108", "Brave";v="108"”],“Sec-Ch-Ua-Mobile”:[“?0”],“Upgrade-Insecure-Requests”:[“1”],“Accept-Language”:[“en;q=0.7”]},“tls”:{“resumed”:false,“version”:772,“cipher_suite”:4865,“proto”:“h2”,“server_name”:“”}},“duration”:0.004022061,“status”:502,“err_id”:“ubixxwa84”,“err_trace”:“reverseproxy.statusError (reverseproxy.go:1272)”}

with the reverse proxy error as I try to go to

The issue for me is that I do not have any more free space in my Nanode to backup with borg and then follow with the solution given here.

Is there another solution?

Nevermind. After adding a volume to my Nanode and mounting it correctly to the /mnt/backup/borg directory, I was able to do the borg backup and just rerunning the update once again solved this issue for me.