AiO 6 NC 26.0.2 still email server error

Hi
I’ve seen several posts about this topic, nothing worked for me yet.
My credentials are correct, of course - a smtp account from MAILERSEND.
Could it be a DNS/Cloudflare problem again?
Nothing in my logs about this.

I can’t click the “i” to get info.
I can’t see the roll down menu list: login, nothing else. I just can clic ‘Authentification required’

Here is screenshot:

I was told NC AiO was the most stable distro of all. So far, I would agree with this statement, but I still don’t understand why I get so many logs. I thought the container system would prevent me from any mistake I would make trying to set the best server environnement and grant me perfect settings made by this community.
Can one please explain, I don’t understand.
I use a 4 core server with 8 gigs of ram on SSD, only few users on my debian server, and using my NC instance is quite slow.
Thank you very much.

Capture d’écran 2023-06-07 à 23.41.20

What kind of logs do you get? Can you post them here?

thanks @szaimen, i’d be glad to share all my logs, but so far they don’t seem to be connected to my email problem … I’m searching all threads about email notification problems on this forum, and i’ll come back here.
Thank you so much for the speed of your answers :+1:

it seems that is was all linked to the Server address port, which can’t be 587.
I’ve tried different emails of mine. Some worked, but only with 465.

So, I’ve passed the test, and received the test email in my personal email account.

Now, I’m facing email notification settings …
I’ve set several notification by email. But I’m not getting any.
I do get an email when trying to renew a password.

I’ve read threads about this, but no solution.
Your guidance is welcome.

Have all a great day… or night :crossed_fingers:

Can you show a full screenshot of https://yourncdomain.com/settings/user/notifications ?

Hi @szaimen
you’re always so fast, thank you so much.
Here are my screen shots:

Capture d’écran 2023-06-12 à 10.40.08
Capture d’écran 2023-06-12 à 10.40.15

The settings look good in general. I think after setting up the mail server only new activities will be send. BTW, did you also set an email address for your account in your personal settings?

yes I did put email address in my account, that’s why I get email for password renewal.
None of our members are receiving email notifications … since the correct settings 2 days ago.

Do they also have the same settings applied and a mail-address configured?

probably not all the same settings for notifications, but they all have an email address configured.

I’m also using several accounts on our AiO instance, and I didn’t get any.

Can you check these?

do you mean can I ask every one about their personal settings? to make sure that all email notifications are not disabled?

Yes. Or you use the Impersonate app to check this (should work if serverr side encryption is not enabled).

Ok, I have activated more email notifications in a couple of accounts. I’m going to share docs and folders with users now.
Thanks for your precious assistance.

Note
Impersonate has become a long process since impersonate logs off instead of going back to the admin account. Do you have this too?

Yes. you could log an issue here: Issues · nextcloud/impersonate · GitHub

Hi, it’s done.

I finally get errors about this :

{"reqId":"j3KxfsMGgyPDBvMPyt55","level":3,"time":"2023-06-13T17:40:44+00:00","remoteAddr":"185.252.235.96","user":"troumpo-camin","app":"mail","method":"GET","url":"/apps/mail/api/messages/25/body","message":"Could not load message","userAgent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.6.1 Safari/605.1.15","version":"26.0.2.1","exception":{"Exception":"OCA\\Mail\\Exception\\ServiceException","Message":"Could not load message","Code":0,"Trace":[{"file":"/var/www/html/custom_apps/mail/lib/Controller/MessagesController.php","line":220,"function":"getImapMessage","class":"OCA\\Mail\\Service\\MailManager","type":"->","args":[["Horde_Imap_Client_Socket",["HICenv","HICflags","HIChdrs","HICdate","HICsize","And 1 more entries, set log level to debug to see all entries"],true,true],["OCA\\Mail\\Account"],["OCA\\Mail\\Db\\Mailbox",5],1,true]},{"file":"/var/www/html/lib/private/AppFramework/Http/Dispatcher.php","line":230,"function":"getBody","class":"OCA\\Mail\\Controller\\MessagesController","type":"->","args":[25]},{"file":"/var/www/html/lib/private/AppFramework/Http/Dispatcher.php","line":137,"function":"executeController","class":"OC\\AppFramework\\Http\\Dispatcher","type":"->","args":[["OCA\\Mail\\Controller\\MessagesController"],"getBody"]},{"file":"/var/www/html/lib/private/AppFramework/App.php","line":183,"function":"dispatch","class":"OC\\AppFramework\\Http\\Dispatcher","type":"->","args":[["OCA\\Mail\\Controller\\MessagesController"],"getBody"]},{"file":"/var/www/html/lib/private/Route/Router.php","line":315,"function":"main","class":"OC\\AppFramework\\App","type":"::","args":["OCA\\Mail\\Controller\\MessagesController","getBody",["OC\\AppFramework\\DependencyInjection\\DIContainer"],["25","mail.messages.getBody"]]},{"file":"/var/www/html/lib/base.php","line":1058,"function":"match","class":"OC\\Route\\Router","type":"->","args":["/apps/mail/api/messages/25/body"]},{"file":"/var/www/html/index.php","line":36,"function":"handleRequest","class":"OC","type":"::","args":[]}],"File":"/var/www/html/custom_apps/mail/lib/Service/MailManager.php","Line":200,"Previous":{"Exception":"OCP\\AppFramework\\Db\\DoesNotExistException","Message":"Message does not exist","Code":0,"Trace":[{"file":"/var/www/html/custom_apps/mail/lib/Service/MailManager.php","line":193,"function":"find","class":"OCA\\Mail\\IMAP\\MessageMapper","type":"->","args":[["Horde_Imap_Client_Socket",["HICenv","HICflags","HIChdrs","HICdate","HICsize","And 1 more entries, set log level to debug to see all entries"],true,true],"INBOX/TRASH",1,"troumpo-camin",true]},{"file":"/var/www/html/custom_apps/mail/lib/Controller/MessagesController.php","line":220,"function":"getImapMessage","class":"OCA\\Mail\\Service\\MailManager","type":"->","args":[["Horde_Imap_Client_Socket",["HICenv","HICflags","HIChdrs","HICdate","HICsize","And 1 more entries, set log level to debug to see all entries"],true,true],["OCA\\Mail\\Account"],["OCA\\Mail\\Db\\Mailbox",5],1,true]},{"file":"/var/www/html/lib/private/AppFramework/Http/Dispatcher.php","line":230,"function":"getBody","class":"OCA\\Mail\\Controller\\MessagesController","type":"->","args":[25]},{"file":"/var/www/html/lib/private/AppFramework/Http/Dispatcher.php","line":137,"function":"executeController","class":"OC\\AppFramework\\Http\\Dispatcher","type":"->","args":[["OCA\\Mail\\Controller\\MessagesController"],"getBody"]},{"file":"/var/www/html/lib/private/AppFramework/App.php","line":183,"function":"dispatch","class":"OC\\AppFramework\\Http\\Dispatcher","type":"->","args":[["OCA\\Mail\\Controller\\MessagesController"],"getBody"]},{"file":"/var/www/html/lib/private/Route/Router.php","line":315,"function":"main","class":"OC\\AppFramework\\App","type":"::","args":["OCA\\Mail\\Controller\\MessagesController","getBody",["OC\\AppFramework\\DependencyInjection\\DIContainer"],["25","mail.messages.getBody"]]},{"file":"/var/www/html/lib/base.php","line":1058,"function":"match","class":"OC\\Route\\Router","type":"->","args":["/apps/mail/api/messages/25/body"]},{"file":"/var/www/html/index.php","line":36,"function":"handleRequest","class":"OC","type":"::","args":[]}],"File":"/var/www/html/custom_apps/mail/lib/IMAP/MessageMapper.php","Line":90},"message":"Could not load message","exception":[],"CustomMessage":"Could not load message"},"id":"6488b0eb0265d"}
{"reqId":"iXP8xtHZ8Kz1tRjSQl5r","level":3,"time":"2023-06-13T17:35:23+00:00","remoteAddr":"185.252.235.96","user":"troumpo-camin","app":"PHP","method":"GET","url":"/apps/mail/api/autoComplete?term=tatiana%40gmail.com","message":"foreach() argument must be of type array|object, null given at /var/www/html/custom_apps/mail/lib/Service/ContactsIntegration.php#93","userAgent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.6.1 Safari/605.1.15","version":"26.0.2.1","data":{"app":"PHP"},"id":"6488b0eb02685"}
{"reqId":"iXP8xtHZ8Kz1tRjSQl5r","level":3,"time":"2023-06-13T17:35:23+00:00","remoteAddr":"185.252.235.96","user":"troumpo-camin","app":"PHP","method":"GET","url":"/apps/mail/api/autoComplete?term=tatiana.vandam%40gmail.com","message":"Undefined variable $userGroups at /var/www/html/custom_apps/mail/lib/Service/ContactsIntegration.php#93","userAgent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.6.1 Safari/605.1.15","version":"26.0.2.1","data":{"app":"PHP"},"id":"6488b0eb0269c"}

One more that is coming back regularly.

{"reqId":"citJIgP2C0WHeW6wtUQ9","level":3,"time":"2023-06-08T22:23:42+00:00","remoteAddr":"185.252.235.96","user":"tatiana","app":"PHP","method":"GET","url":"/ocs/v2.php/apps/spreed/api/v1/chat/vtbmuw9t?setReadMarker=0&lookIntoFuture=1&lastKnownMessageId=3519&includeLastKnown=0","message":"Redis::get(): php_network_getaddresses: getaddrinfo for nextcloud-aio-redis failed: Name does not resolve at /var/www/html/lib/private/Memcache/Redis.php#56","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/113.0.0.0 Safari/537.36","version":"26.0.2.1","data":{"app":"PHP"},"id":"6488b373a7b34"}

I’ve just received an email mentioning an error:

This is the mail system at host http://mo544.mail-out.ovh.net.
I’m sorry to have to inform you that your message could not
be delivered to one or more recipients. It’s attached below.

For further assistance, please send mail to postmaster.
If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

**tatiana**@gmail.com: host http://gmail-smtp-in.l.google.com[http://173.194.76.26]
said: 550-5.7.26 This mail is unauthenticated, which poses a security risk
to the 550-5.7.26 sender and Gmail users, and has been blocked. The sender
must 550-5.7.26 authenticate with at least one of SPF or DKIM. For this
message, 550-5.7.26 DKIM checks did not pass and SPF check for [http://rez0.net]
did not pass 550-5.7.26 with ip: [http://188.165.47.147]. The sender should visit
550-5.7.26 Prevent mail to Gmail users from being blocked or sent to spam - Gmail Help for
550 5.7.26 instructions on setting up authentication.
k25-20020a7bc419000000b003f7f4b1dd27si5714741wmi.13 - gsmtp (in reply to
end of DATA command)

This one was sent to my admin account by my registrar which hosts my domains and provide an email server (ovh, france).

This same user, Tatiana, used a different email address before, on hush, she didn’t receive notifications by email neither. I changed her email address with one I have at autistici (italy) and I can receive email notifications, no problemo.

Do you think this could be a problem on the mail server side, or something wrong with the notifications sendings?

Thanks @szaimen

that same user received an email in her gmail account to advise her her email address was changed …

Hi @szaimen

Do you think this could be a problem on the mail server side, or something wrong with the notifications sendings? The mail is marked unsigned, though gmail receives password renewal notification and hush received notification when her email address was changed.

I am not sure about this. It could also be a bug on nextcloud/server side.