After upgrading NC to latest - code integrity

update_problems
integrity-check
nc12

#1

using NC version 12.0.4
There were problems with the code integrity check. More information… how to remove error message or fix the root cause?

[root@owncloud nextcloud]# sudo -u apache php occ integrity:check-app mail

  • EXTRA_FILE:
    • css/mail.scss:
      • expected:
      • current: f007a3c24a3815a3207e433c0d4614e2da35fef176fe859dc60595e530a0306924249dcce2f3d4d8bb7a7b9bcac309b56843908280be85dfc90e638497048a08
    • krankerl.toml:
      • expected:
      • current: 191dadfc691a74800aec251c868704013d8bc8e3f520662fc76d80c7e488d0297ff1ca6d340dbb578c07ec1b8d497f6f259f5d42c53fd302295a9e9904eb32ac
    • l10n/ka_GE.js:
      • expected:
      • current: 7c3ff76f1a2b9bdac7e7017030f40a5b9b3da62a3ac4b48359a439e541da2e5ebb3f1718560725a5aac1d1aaad7ee0ad003b2b622378cd947f96759ab37e82e8
    • l10n/ka_GE.json:
      • expected:
      • current: 857166e6a0ffebe966fb5513c97ff343b4de083eef38f6994d5337d9ce96946afa59dd86ed5017fbfb649a529cbc2b224b200c40251a3ea571096d669f2b5493
    • lib/Contracts/IAvatarService.php:
      • expected:
      • current: 75942c6dfd84fcc3e5d0dcad5174f6c7bdecbbffba888518337f35757b9021fd78c0651dfa1cbde030ae72fbd2d5c8803333725cc34a7d65d3c0fc1e54eb673b
    • lib/Controller/AvatarsController.php:
      • expected:
      • current: 7d3913c8e0a0ce66cd99bcbb4116a8ef483d949e56becf0cae5feb759278472eabe40aadcea206c57ca0a90e1aad220d981d36ab3f2ad98750b7a976947da98f
    • lib/Http/AvatarDownloadResponse.php:
      • expected:
      • current: 3c8988cc823506f0345dd4cc96fc40cf92e7c3ccf4dfe2ad7048679ec9fe4738528fa71c0139ffe7055de3beb2c750ae1ef710bced059fdd296b24828831bb19
    • lib/Http/CacheHeaders.php:
      • expected:
      • current: 179c4b008ee77dc3f25d82b797d64111feb9a5c8fb54f7788860e14b2f814a59681a4b49550dd595012d6503748afcb4f82cb51f5dd06ac5cd3a8ec0a73df578
    • lib/Http/JSONResponse.php:
      • expected:
      • current: e8e5d2d985ab38f832666c1e49db4a26231266c58eec50e1dc60248b32eb45388254782e75d84347b18355fe78ab2a4ec2255f294f3ee1079c94211e08f43db6
    • lib/Service/AvatarService.php:
      • expected:
      • current: e305b35c89281bae2131bdd50e09ed3659c2da3663d9c893c0819741243c1788316fbc6848bfdcaad08bedd0cc9f9e1e2b60f82bc8d2048d969412bda74d8006
    • vendor/cerdic/css-tidy/.gitignore:
      • expected:
      • current: 0e7f0b9a20f344cdc9fd1dd4035e98657417d1f11f85395e40c9e5b54091ae86ebe0fa5b2e2da1c9eed69d92de55a635ad7d4877f34da90870f952cafdb8b9d4
    • vendor/cerdic/css-tidy/composer.json:
      • expected:
      • current: 63d3840bc0ec4f7067d2832513f474f17b537ce4c6ccc05a9d25488c03889706d6eb908e92e3c328d1737a58fa382d374e6eb64e7d100fa220b301124447a99a
    • vendor/ezyang/htmlpurifier/INSTALL:
      • expected:
      • current: 324788c5fa26e9d4dbe18d502381ad94ae88069e5e0708b86246a00be1fe7e15362ca57ec5f4bfc1358851024777d6d6620c1b862af21c187e445b3862117d37
    • vendor/ezyang/htmlpurifier/INSTALL.fr.utf8:
      • expected:
      • current: eba2b845fd5d6e82aabde256dd5c34d643962957463f232ba275504f62875186e9d41b12599a290066bf800380407237ba0accfdee8157473bc81163c72542ff
    • vendor/ezyang/htmlpurifier/NEWS:
      • expected:
      • current: 04d6bbc4f194faab0e6f3622516221228cd73b41e467c42e8babc30e70337ab623f9dd82e4e53c3aa39ec6b59e18a21f8e1ff27469b74d9f13437aa4c736c260
    • vendor/ezyang/htmlpurifier/TODO:
      • expected:
      • current: 4be94318caaa4cbf1b4486945fa378cb04d312b6a4657ff1bd49eb760bff543457073eca399c89079491ad75606b821e8a5c6a17749d7d6677e4167b28879e22
    • vendor/ezyang/htmlpurifier/VERSION:
      • expected:
      • current: 97e85c1fe41457fb779a0268c109d743079f2ff7461d81f64ac7e9a4e1fc0f6c42e1170f835fbae9d136667da7492f88faf239c7670d97213508265c2b62aa45
    • vendor/ezyang/htmlpurifier/WHATSNEW:
      • expected:
      • current: d2cc5e02f4f7ab8f216735841d5c8af2720224b3bc8954dfe6ebe5c57a17df05ebce7a0f8367f3d4e3eb302917b624d2d67271c04733a4bef58b56754cf08aca
    • vendor/ezyang/htmlpurifier/WYSIWYG:
      • expected:
      • current: 719438bff87d39076787403437a212ed1db6464b4bbb61be2de17197cedd2e9bb0683097a776400fb92129bd0a6ed8e2cc34177a5b47e338e8bf12963e71bf8f
    • vendor/ezyang/htmlpurifier/composer.json:
      • expected:
      • current: 25ffaa480b115605548a6512b4370f4f6e46e3aa6a693a0949951fd297f20575617eaac0c9a5a1dd6d7e4de28bb6a8fe5085099cc8cebb8096c996ebc7437bab
    • vendor/ezyang/htmlpurifier/phpdoc.ini:
      • expected:
      • current: 7b8f24f6a3be44763fbdab862d6a36b4bd4110cafd50320bdc95ae9a8b4046216405086c4087564111be2f20ff1201a5172fd3a99402c7ee6bacdc5b30594a5c
    • vendor/kwi/urllinker/composer.json:
      • expected:
      • current: 641a30d7ce54643e936785dd6e5aad6e6d2fb96939633bca831b70f9ab795b6f2f06cd6755ae7dcb2516846b2486276a1132110534fbe48add83e09f8aa5e08c
        [root@owncloud nextcloud]#

#2

How did you upgrade? You probably just overwrote the folders, this way you keep old files of code that do not exist in the new version. For a proper upgrade, you delete all old code (just keep the data and config folder), then upload the new code. Now there are a dozen of files too much, you can also search and delete them, run the integrity test again.


#3

here is the code what i used to upgrade

sudo -u apache php occ upgrade

what code? but is it possible to see this error on database?

thanks


#4

ok fixed already

thanks for your hint