After Upgrading from v17.0.3 to v18.0.0.10, ONLYOFFICE cannot be reached. Please contact admin

Good-day folks,

So after upgrading my NC instance from v17.0.3 to v18.0.0.10, where I had ONLYOFFICE integrated as a docker image, I am now running into the following error message:

"ONLYOFFICE cannot be reached. Please contact admin"

I have a feeling this is related to the fact that the settings for the ONLYOFFICE app are still pointing to the docker instance. How do I remove this and give way to the new integrated ONLYOFFICE that ships with v18.0.0? I already tried simply stopping the docker service, but that didn’t help much.

I have the same issue, did you find a fix?

No, not yet. Hopeful that someone from the NC Support team will see this thread and lend some assistance.

1 Like

Hi @marshalleq it appears I have solved my problem by doing the following (see if it helps you). I’m running a Debian 10 server with the Only Office server running in a Docker container. So I had to stop the Docker service and then remove the existing server settings for the Only Office app. Here’s a step-by-step:

1. Stop the Docker service

systemctl stop docker.service

2. Install the “Community Document Server” app

3. Remove the current ONLYOFFICE settings
I did this by clicking on “Settings”, then scrolling down to “ONLYOFFICE”. Under the Server Settings, delete the values for “Document Editing Service Address” and “Secret”, then click save. Make sure they are both blank after refreshing the page a couple of times.

Now go back to files and open a document and confirm it works. It worked for me without doing anything else beyond this. Also, when I went back into Settings, I now see this value for the “Document Editing Service Address” and the “Secret” value is empty.


Hope this helps you out.

Thanks for that. I have tried various iterations of this. It was difficult just to know that URL which is crucial and for some reason missing from the documentation - probably because there really isn’t any documentation for this which is disappointing. I’ll try removing the settings again though in case as I didn’t do this after the last few fixes. Did you have anything in your advanced settings? Thanks.

@marshalleq No, I do not have anything extra under the “Advanced” section. All are blank.

I had there “” which worked a few months ago. I guess since the update from 19.0.3 to 19.0.4 it stopped working. I got the same error when clicking on a docx:

“ONLYOFFICE cannot be reached. Please contact admin”

I did that, your suggestion, but it didn’t help. now I have no ONLYOFFICE functionality on .docx documents any more at all!