After upgrading from nc 28 to 29, the External storage support app becomes unusable

After upgrading from nc 28 to 29, the External storage support app becomes unusable

`

Error: This application cannot be enabled because it makes the server unstable

`

Here in Nextcloud 29.0.2 it works. Maybe you can uninstall and reinstall the app. First copy your configurations. Do you have logs?

I tried to reinstall many times, but the problem still exists. Even if I reinstall nc 29 and not import the original database, it still doesn’t work. :joy: :joy: :joy:

This is my log

Please help me take a look. Thank you.

Please set your log level to something more reasonable like 2. 90% of what you posted is just debugging noise that isn’t related to your issue.

What installation method?
How precisely are you upgrading?
What platform?
Your config via occ config:list system

Basically all the elements of the support template you didn’t fill out. :slight_smile:

What installation method?

  1. Run setup-nextcloud.php to install the latest version 29.02
  2. Import the original 28.05 database and move the original data directory to replace the existing data
  3. Run php occ upgrade
  4. Run php occ files:scan --all

What platform?

MAC OSX

nginx 1.21

php 8.25

mysql 8.0

occ config:list system

After setting the level to 2, the problem was reproduced again, and no logs were generated.

Oh, so you didn’t just upgrade, but you also migrated to a new instance. That’s an important detail you didn’t mention. :slight_smile:

Did you also copy over your config/config.php from your prior deployment (which contains your secret)?

I’m so sorry, I overlooked this

The following is the config.php I’m using and the config.php I migrated before. The secret part is indeed not synchronized. Please tell me what to do, thank you

using

before

Normally you would copy your “before” config.php to the new (replacement) server before bringing it online[1].

If the new server hasn’t been used yet, you can manually copy over the secret and passwordsalt values. The safest course of action, however, would be to do the migration again so that your new instance never runs with the incorrect secret and passwordsalt values against your restored database.

[1] https://docs.nextcloud.com/server/latest/admin_manual/maintenance/migrating.html

OK,thank you
I have solved this problem. However, I will still study the manual you mentioned in case of emergency.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.