After Upgrade to 16.0.0

#1

Nextcloud version 16.0.0
Operating system and version linux with kernel version 3.10.0-962.3.2.lve1.5.24.10.el7.x86_64
Apache version 2.4.39
PHP version 7.2.10

Since running the Softaculous automated script to upgrade to 16.0.0, I have seen nothing but “Maintenance Mode” when I try to access NextCloud. This has been the case for the past three hours or so now.

Previously when I have run NextCloud updates, all has worked without a hitch so I am not sure what the issue is this time around. Anyone have any ideas?

This installation is running on a shared server at InMotionHosting. I have tried backing off the PHP version from 7.2 to 7.1 and that changed nothing.

Thanks in advance for any help you all can provide.

#2

As described in other requests, please check your web server and Nextcloud log file first to find out what the root cause of your problem is. I think, changing the PHP version without even knowing what has caused the problem is the wrong way to go.

#3

I saw other responses to such issues on a Google search that seemed to indicate that dropping back to PHP 7.1 would solve the issue, so that is why I tried that. However, as noted in my original post, that was to no avail.

As for your suggestion of checking the Nextcloud log file, where might I find that in the Nextcloud directory structure? I see nothing obvious that is a log file.

#4

Under the Nextcloud root directory you will usually find a symbolic link called datawhich points to your data directory, where by default the Nextcloud log file should be found.

#5

As I have said, this is a shared server at InMotionHosting, so I do not have direct access to the OS. As is typical for shared accounts, I have access only through cPanel and the File Manager applet included within it. It does not have symbolic links. What is the actual path to the data directory? What I have found so far is core/Data and that directory contains only two script files: LoginFlowV2Credentials.php and LoginFlowV2Tokens.php.

#6

I would recommend to contact your hoster for information how the software is installed in your environment. I think this couldn’t be answered in this forum.

#7

Did you upgrade the SQL server to Barracuda format before updating to 16.0.0?

https://docs.nextcloud.com/server/15/admin_manual/configuration_database/mysql_4byte_support.html

#8

I found the problem. The Maintenance boolean in config.php was set to True. All I had to do was set it to False and the software came back online as it should.

Thank you, Sanook, for sending the link as that was what led me to the config.php file in which I found the problem.

1 Like