After upgrade (12.0.5->13.0.1) clients forget about selected (group)folders after logout or reboot

Hi all,

Server: Ubuntu 16 LTS - NC 13.0.1
Clients: macOS HS with - NC client 2.3.3 (84)

After upgrading the server to 13.0.1 (from 12.0.5) we have an issue with about 5-10 users (clients) that for some reason don’t stick to their selective sync. All shared folders are groupfolders - but after logout/login or reboot of their laptops some (not all) of their selective sync folders are missing out.

What puzzles us right now is why some selective folders will be remembered (and some are even bigger in size than the ones that disappear) and others continously and reproducably keep missing out. It’s not the (group)folder itself, as other users have the same folder just sticking around - even when rebooting their systems.

Any clues on where to start checking? Already tried starting over with a clean local nextcloud folder with-or-without removing the complete account from the desktop-client. Tried (as per hint found by a member of our support staff) setting quota’s (which were at unlimited) to 999 GB for some of these users, etc.

Edit: This afternoon one of our users called us again, she lost one of the group-folders again and not only did these not show up in her desktop-client - they also didn’t show on the browser when logging in. Additional information (which seems rather relevant now) is that we use (Open)LDAP for authorisation and authentication (with either multi-user groups or user-specific groups). In this case the folders in question (that are being lost) are mostly user-specific groups.

Any directions are welcome! Thanks,

Tom

Hi all,

Luckily getting closer to determining what happens, but not sure why this ‘sometimes works - sometimes doesn’t’. The latter being the issue obviously. Last night when editing my own post, one of our users did show her own group when logging in as admin and looking at her account. This morning it didn’t.

The difference between the normal groups and this one is our primary group is only identified by gidNumber in the users account. All other groups are memberUid - which obviously has been set in the correct page within the LDAP settings. For some reason the gidNumber isn’t always resolved correctly. Even this morning when the users primary group was missing - other users just showed their primary group (through gidNumber fine).

Sifting through https://github.com/nextcloud/server/commit/8db21ad8c894332b85a37bef28818604a175db23 currently but I don’t spot anything that indicates the inconsistent behaviour.

Tom

I have a similar problem: I added a new group-folder yesterday, but it does not show up in the desktop-client (ubuntu 12.04). In the “Settings” of the client had to add the new folder, but it still did not sync. It seems the nextcloud-version has been updated lately.