After updating docker (The 'nextcloud-aio-mastercontainer' container was not found.)

I was doing something else to my computer and in the process I did sudo apt update and I saw it updated docker and hoped nothing changed with nextcloud. But latter after restarting my computer I realized next cloud did not boot. so not knowing what to do I did

sudo docker run \
--sig-proxy=false \
--restart always \
--publish 80:80 \
--publish 8080:8080 \
--publish 8443:8443 \
--volume nextcloud_aio_mastercontainer:/mnt/docker-aio-config \
--volume /var/run/docker.sock:/var/run/docker.sock:ro \
nextcloud/all-in-one:latest

hoping to start next cloud and I got this error

Trying to fix docker.sock permissions internally...
Creating docker group internally with id 998
WARNING: No swap limit support
It seems like you did not give the ```mastercontainer the correct name? (The 'nextcloud-aio-mastercontainer' container was not found.)
Using a different name is not supported since mastercontainer updates will not work in that case!
If you are on docker swarm and try to run AIO, see https://github.com/nextcloud/all-in-one#can-i-run-this-with-docker-swarm

after running that thinking somthing happend I ran

docker volume ls

DRIVER    VOLUME NAME
local     nextcloud_aio_apache
local     nextcloud_aio_database
local     nextcloud_aio_database_dump
local     nextcloud_aio_mastercontainer
local     nextcloud_aio_nextcloud
local     nextcloud_aio_redis


but all the volumes are still there.

I honestly have no Idea of were to start in order to fix this so any help is welcome.

Hi, apparently you missed this line in the docker run command: all-in-one/readme.md at 64bdfb535cd511c8ba334d911fdf392fe562db3f · nextcloud/all-in-one · GitHub

timothy@timserver:~$ sudo docker run \
> --sig-proxy=false \
> --name nextcloud-aio-mastercontainer \
> --restart always \
> --publish 80:80 \
> --publish 8080:8080 \
> --publish 8443:8443 \
> --volume nextcloud_aio_mastercontainer:/mnt/docker-aio-config \
> --volume /var/run/docker.sock:/var/run/docker.sock:ro \
> nextcloud/all-in-one:latest
[sudo] password for timothy: 
docker: Error response from daemon: Conflict. The container name "/nextcloud-aio-mastercontainer" is already in use by container "5f6fc416942fe1dbf0b196a6549d5423a03863c16e12ca37664beecad93d48e2". You have to remove (or rename) that container to be able to reuse that name.
See 'docker run --help'.
timothy@timserver:~$ 

I don’t think that’s the problem.

I have also tried it with

 --init \

Can you post the output of sudo docker ps -a here?

CONTAINER ID   IMAGE                                                 COMMAND                  CREATED         STATUS                          PORTS                                                                                                                               NAMES
bc0bfc27f5d2   nextcloud/all-in-one:latest                           "/start.sh"              21 hours ago    Restarting (1) 24 seconds ago                                                                                                                                       youthful_elgamal
52fbdd8b1f95   nextcloud/all-in-one:latest                           "/start.sh"              2 days ago      Exited (1) 19 hours ago                                                                                                                                             nice_liskov
13b954dc52ba   nextcloud/aio-apache:latest                           "/start.sh /usr/bin/…"   12 days ago     Exited (128) 3 days ago         80/tcp, 0.0.0.0:443->443/tcp, 0.0.0.0:443->443/udp, :::443->443/tcp, :::443->443/udp                                                nextcloud-aio-apache
25f45869346e   nextcloud/aio-notify-push:latest                      "/start.sh"              12 days ago     Exited (128) 3 days ago                                                                                                                                             nextcloud-aio-notify-push
78da3c2bc6fa   nextcloud/aio-nextcloud:latest                        "/start.sh /usr/bin/…"   12 days ago     Exited (128) 3 days ago         9000/tcp                                                                                                                            nextcloud-aio-nextcloud
cf0f75802c79   nextcloud/aio-imaginary:latest                        "/start.sh"              12 days ago     Exited (128) 3 days ago                                                                                                                                             nextcloud-aio-imaginary
14640932e344   nextcloud/aio-redis:latest                            "/start.sh"              12 days ago     Exited (128) 3 days ago         6379/tcp                                                                                                                            nextcloud-aio-redis
778160079f85   nextcloud/aio-postgresql:latest                       "/start.sh"              12 days ago     Exited (128) 3 days ago         5432/tcp                                                                                                                            nextcloud-aio-database
5f6fc416942f   nextcloud/all-in-one:latest                           "/start.sh"              12 days ago     Exited (128) 3 days ago         0.0.0.0:80->80/tcp, :::80->80/tcp, 0.0.0.0:8080->8080/tcp, :::8080->8080/tcp, 0.0.0.0:8443->8443/tcp, :::8443->8443/tcp, 9000/tcp   nextcloud-aio-mastercontainer
8e3eacac2871   nextcloud/aio-watchtower:latest                       "/start.sh"              12 days ago     Exited (0) 12 days ago                                                                                                                                              nextcloud-aio-watchtower
616c44b7ac33   nginx                                                 "/docker-entrypoint.…"   2 weeks ago     Exited (0) 2 weeks ago                                                                                                                                              deepracer-0-viewer_proxy_1
5795a27fb6eb   hello-world

Can you run sudo docker start nextcloud-aio-mastercontainer ? If that runs correctly, you should be able to open the aio interface on port 8080 or 8443.

timothy@timserver:~$ sudo docker start nextcloud-aio-mastercontainer
[sudo] password for timothy: 
Error response from daemon: unknown or invalid runtime name: nvidia
Error: failed to start containers: nextcloud-aio-mastercontainer
timothy@timserver:~$

This seems to be the problem that you need to fix

for future viewers of this conversation here is the solution.
I was updating and removing old NVIDIA drivers and missed this.

-ChatGPT
Make sure you have installed the NVIDIA Container Toolkit. This toolkit provides necessary components to enable Docker to access NVIDIA GPUs.

Install the NVIDIA runtime

sudo apt-get install -y nvidia-docker2
sudo systemctl restart docker

Thank you so much for your help :slight_smile:

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.