After update webdav calendar certificate is not trustable

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version : 20.0.8
Operating system and version Ubuntu 20.04 LTS
Apache or nginx version : Apache 2.4.41
PHP version : PHP 7.4.3

The issue you are facing:
After Updating my nc from 20.0.6 to 20.0.08 my webdav isn’t working any more. I get the message: The certificate isn’t trustable connection failed
the certificate is from “ph6bahrrcimifo23.myfritz.net” but that isn’t my real one cause I’m using Lets encrypt and on my nc web and sync clients everything is fine and using lets encrypt only webdav is broken and uses this wrong certificate
Any ideas ?

Your description doesn’t really show a direct relation between the Nextcloud update and the certificate problem for me. If the self-signed MyFritz certificate of your AVM router is shown instead of your Nextcloud server certificate you’ve most likely enabled remote access to your internet router on port 443/tcp which blocks access to the Nextcloud server. I see the following possible options to fix the problem:

  • Disable remote access to your router or move it to a different tcp port if that is possible.
  • Set-up a port forwarding on port 443/tcp to your Nextcloud server or use a different port to access the server.
  • Change your Nginx configuration so that it correctly acts as a reverse proxy.

Thank you for your answer
the remote access is disabled already and I can access my NC without any issues from outside through port 443

So the problem is fixed now, right?

no no it´s still there :smiley: that’s the problem I don’t know why

Sorry, I’m totally confused now. You said “I can access my NC without any issues from outside through port 443” and at the same time you said “the certificate is from “ph6bahrrcimifo23.myfritz.net ” but that isn’t my real one”?!

All DAV protocols are running over https and usually the same certificate is used for it. If a different certificate is used for CalDAV than for the Nextcloud https access you are most likely redirecting this specific connection to a differen host or your internet router?! In this case I would recommend to compare your Nginx configuration with the last working copy from your regular backup to find any difference in it.