After switching to new instance of redis server now I am not able to login to nextcloud

Support intro

I was upgrading the stack and started with redis server I am using the same old data.dump from the old redis server and started new redis server container using docker compose.

Now the redis server is working fine and nextcloud login page shows up but entering login credantials doesnt lets me log in I am not getting any error.

I cleaned my nextcloud.log and thought new log file will be easy to spot but I dont see any error either. Its quite critical, as i have been using nextcloud since 2020 beginning of that year.

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 24.0.2
Operating system and version (eg, Ubuntu 20.04): Ubuntu 18.04 LTS
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.54
PHP version (eg, 7.4): 8.1

The issue you are facing:
I am not able to login

Is this the first time you’ve seen this error? (Y/N): No

Steps to replicate it:

  1. start new docker container of redis with different port (actually original 6379)
  2. updated /etc/php/8.1/apache2/php.ini
  3. updated config.php
  4. restarted php8.1-fpm
  5. restarted apache2
  6. tried to login and didnt log me in . thats it no error.

The output of your Nextcloud log in Admin > Logging:

Getting nothing in the log file.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => 'oce4rsysxqpd',
  'passwordsalt' => 'RvVYrpLRslm39+4LJgeidQmjl5qAFd',
  'secret' => 'O9WdlpA+gi7XgigCEcjRsdfsrzH6s0MHMoVVN3vf7iCJu5p5R',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => 'true',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => '192.168.1.56',
    'port' => 6379,
    'timeout' => 3,
    'password' => '',
    'dbindex' => 0,
  ),
  'trusted_domains' => 
  array (
    0 => '192.168.1.56',
    1 => 'mywebsitedomain.com',
    2 => 'home.local',
  ),
  'has_internet_connection' => true,
  'connectivity_check_domains' => [
        'devilsan.com',
        'access.devilsan.com',
  ],
  'check_for_working_wellknown_setup' => true,
  'check_for_working_htaccess' => true,
  'logfilemode' => 0640,
  'loglevel' => 2,
  'loglevel_frontend' => 2,
  'syslog_tag' => 'Nextcloud',
  'syslog_tag_audit' => 'Nextcloud',
  'logfile' => '/var/log/nextcloud/nextcloud.log',
  'datadirectory' => '/media/storage/data',
  'dbtype' => 'mysql',
  'version' => '24.0.2.1',
  'overwrite.cli.url' => 'https://192.168.1.56/nextcloud',
  'dbname' => 'nextcloud',
  'dbhost' => '192.168.1.64:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'dbUsernxt',
  'dbpassword' => 'secretPasswordRemoved!',
  'installed' => true,
  'session_lifetime' => 86400,
  'session_keepalive' => true,
  'has_rebuilt_cache' => true,
  'updater.release.channel' => 'stable',
  'maintenance' => false,
);

The output of your Apache/nginx/system log in /var/log/nextcloud/nextcloud.log:

log file is empty

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.
Not getting any error either.

I think redis requires a password by default now.

Also, your docker container logs may have some useful info.

Thanks @KarlF12 , somehow I was able to log the next day. I did not change anything. it seems to be working fine now