After new Installation Login in the Webfrontend is not possible


i am very new at Nextcloud (i tried it first yesterday) and wan’t to run Nextcloud on a RasberryPi for me as a private User.

My RaspberryPi is running Rasbian which is based on Debian Stretch 9 with all patches.

I tried to install Nextcloud twice. I tried different Ways.

The first way which is described here is based on the Webserver nginx + postgresql and the second one is using Apache2 + MariaDB.

On both Methods i got at the end a Login Screen in my Webbrowser (Safari and Chrome tested). But it took a long time loading is finished. And then i can’t login. I am very sure that use the right credentials. It seems that it is not possible to hit the Button for login, so i think that could be a problem with PHP, but my knowledge is not good enough to resolve this by myself. The Logfile in data/nextcloud.log is empty and the Webserver Logs did not give a hint what the Problem could be.

I am using the latest Version of Nextcloud (i think it is from 28.04.2018).

Can someone Point me to a URL where i can find out how to fix that?


1 Like


i totally agree to @Sanook advice of using nextcloudpi downloadable from the link he provided.

i just think that you should know what it’s all about.
nextcloudpi just offers installing help (setting up, chosing sane settings, etc) especially for the unexperiened first-timers.
so i would suggest (as well) to grab this image, flash it to your sd-card and then follow the instructions given.

@nachoparker and his crew are maintining this piece of software in a great way… and in terms of problem youre gonna be helped by using the ncp-tag here in the forum and filing your questions here

good luck

@Sanook @JimmyKater

Thank you for your answers. Unfortunately I have to say that this possibility was my very first attempt to install Nextcloud. Unfortunately it was not possible for me to download the offered image from until now. Any attempt, whether from the browser or from the CLI with Curl, will cause the download to be aborted. Times after 200 MB times even at 800 MB. Unfortunately, the server is configured in such a way that interrupted downloads cannot be resumed, but start from the beginning. I couldn’t find an alternative server to download. Therefore, this installation option is currently out of the question.


that’s the first time I hear of download problems. Anyhow, there’s like 30 seeds. You should be able to download through torrent in two minutes

edit: tried to download myself the image. No problems

As an Example here:

curl -o NextCloudPlus_04-20-18.tar.bz2
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
64 790M 64 507M 0 0 1239k 0 0:10:52 0:06:59 0:03:53 1205k
curl: (56) Unexpected EOF

When i click on the link with torrent i got only a File of 64KB. This seems not the right Image.

OK, but my Question is not how to Download something, i try to figure out why i can’t login to the Webfrontend.


just downloaded it w/o any problems (roundabout 800 mb)… so if you @betamax65 don’t have torrent, just tell me and i’ll provide you with a downloadlink

No i did nit have torrent. Would be nice if you can point me to an alternative download server.


sorry, but this is a small project and only have that server. I tested your curl command and it works perfectly for me, so there must be some networking problem with you or from you to my hosting provider.

it’s still easy to

install transmission gtk -> open that torrent

you have a private email (here in your account) waiting with a link

1 Like

It does not matter. I will try in the evening some other downloads to find out if this is a general Problem on my side.