After NC 16 Upgrade - "Could not find resource" Error with some apps

Hey guys,

since the upgrade to NC 16 i have some errors in my nexcloud log, that i cant get a hold off. But i am not sure, if it is a bug in the apps or the server or something outside NC. Unfortunatly i wasn’t able to find any other error report which fits my problem.

So i would like to know, if anyone has (had) the same errors or can point me to the right cause of the problem. I could then open a ticket without wasting the time of the developers.

First some specs:

Nextcloud version: 16.0.0.9
Operating system and version: FreeBSD11.2 (iocage)
Apache or nginx version: nginx 1.14.2_13
PHP version: 7.3.4_2
Announcementcenter: 3.5.1
Spreed: 6.0.0

My Issue:

For example, if i open the announcementcenter with an admin account (admins are set to create an new announcements on my instance) there always appear three different ‘could not find resource’ errors in my log:

[...]"app":"cssresourceloader","method":"GET","url":"/apps/announcementcenter/","message":"Could not find resource vendor/select2/select2.css to load"[...]

[...]"app":"jsresourceloader","method":"GET","url":"/apps/announcementcenter/","message":"Could not find resource vendor/select2/select2.js to load"[...]

[...]"app":"jsresourceloader","method":"GET","url":"/apps/announcementcenter/","message":"Could not find resource js/oc-backbone-webdav.js to load"[...]

If a user opens the announcementcenter just one error appers in the log (most likely because it does not load the part where the admin could write a new announcement):

[...]"app":"jsresourceloader","method":"GET","url":"\/apps\/announcementcenter\/","message":"Could not find resource js\/oc-backbone-webdav.js to load"[...]

I`d normally open a ticket at the announcementcenter repo, but i see similar errors on spreed app (talk):

[...]"app":"jsresourceloader","method":"GET","url":"\/apps\/spreed\/","message":"Could not find resource vendor\/select2\/select2.js to load"[...]

[...]"app":"cssresourceloader","method":"GET","url":"\/apps\/spreed\/","message":"Could not find resource vendor\/select2\/select2.css to load"[...]

There are no errors in nginx or php-fpm logs.

Does anybody have a clue, how i could get to the source of this errors? Is it possible both apps have a bug?

I’m thankful for any advice.

Greetings,
HellAdmin

Same error’s here,

NC-V: 16.0.0
OP-System: Debian 9
Apache: Apache/2.4.25
PHP: 7.3.5

Same here. Tried it two times with a clean installation.

Error appears with multiple apps. E.g.:

{… ,“app”:“jsresourceloader”,“method”:“GET”,“url”:"/index.php/apps/spreed/",“message”:“Could not find resource vendor/select2/select2.js to load”, …}

{… ,“app”:“cssresourceloader”,“method”:“GET”,“url”:"/index.php/apps/spreed/",“message”:“Could not find resource vendor/select2/select2.css to load”, …}

{… ,“app”:“jsresourceloader”,“method”:“GET”,“url”:"/index.php/s/BWW2WyN2mZyCi2d",“message”:“Could not find resource core/vendor/marked/marked.min.js to load”, …}

The folder /core/vendor/ only contains “zxcvbn”. No select2, marked or whatsoever. So it is kind of obvious that these files cannot be found.

Server configuration detail

Operating system: Linux 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1+deb9u2 (2019-05-13) x86_64

Webserver: Apache/2.4.25 (Debian) (fpm-fcgi)

Database: mysql 8.0.16

PHP version: 7.3.5-1+0~20190503093827.38+stretch~1.gbp60a41b

Modules loaded: Core, date, libxml, openssl, pcre, zlib, filter, hash, Reflection, SPL, sodium, session, standard, cgi-fcgi, mysqlnd, PDO, xml, apcu, calendar, ctype, curl, dom, mbstring, fileinfo, ftp, gd, gettext, iconv, imagick, intl, json, exif, mysqli, pdo_mysql, apc, posix, readline, shmop, SimpleXML, sockets, sysvmsg, sysvsem, sysvshm, tokenizer, wddx, xmlreader, xmlwriter, xsl, zip, Phar, Zend OPcache

Nextcloud version: 16.0.0 - 16.0.0.9

Updated from an older Nextcloud/ownCloud or fresh install:

Where did you install Nextcloud from: unknown

Signing status

Array
(
)

List of activated apps
Enabled:
 - accessibility: 1.2.0
 - activity: 2.9.1
 - bruteforcesettings: 1.3.0
 - cloud_federation_api: 0.2.0
 - comments: 1.6.0
 - dav: 1.9.2
 - federatedfilesharing: 1.6.0
 - federation: 1.6.0
 - files: 1.11.0
 - files_pdfviewer: 1.5.0
 - files_rightclick: 0.13.0
 - files_sharing: 1.8.0
 - files_texteditor: 2.8.0
 - files_trashbin: 1.6.0
 - files_versions: 1.9.0
 - files_videoplayer: 1.5.0
 - firstrunwizard: 2.5.0
 - gallery: 18.3.0
 - logreader: 2.1.0
 - lookup_server_connector: 1.4.0
 - nextcloud_announcements: 1.5.0
 - notifications: 2.4.1
 - oauth2: 1.4.2
 - password_policy: 1.6.0
 - privacy: 1.0.0
 - provisioning_api: 1.6.0
 - recommendations: 0.4.0
 - serverinfo: 1.6.0
 - sharebymail: 1.6.0
 - spreed: 6.0.0
 - support: 1.0.0
 - survey_client: 1.4.0
 - systemtags: 1.6.0
 - theming: 1.7.0
 - twofactor_backupcodes: 1.5.0
 - updatenotification: 1.6.0
 - viewer: 1.0.0
 - workflowengine: 1.6.0
Disabled:
 - admin_audit
 - encryption
 - files_external
 - user_ldap

After upgrade NC from 15.0.7 to 16.0.1, I am also getting some errors:

[jsresourceloader] Error: Could not find resource core/vendor/marked/marked.min.js to load

GET /s/EKPxps9KRZgjkRs
from 110.44.115.207 at 2019-05-17T11:37:39+07:00

About Setup:

Nextcloud version: 16.0.1
Operating system and version: Ubuntu 16.04.6 LTS
Apache version: Apache 2.4.18
PHP version: 7.2.16

Updated to 16.0.1. Still getting the same errors. Still not able to make calls via the web interface.

Updated to 16.0.1 (from 15.0.7)
Also just saw this error
Could not find resource core/vendor/marked/marked.min.js to load

I do not have nextcloud talk enabled.

I also have the same problem. I have encountered this error since updating to 16.0.1.

{"reqId":"TOKEN","level":3,"time":"2019-05-20T16:34:52+09:00","remoteAddr":"IP-ADDREESS","user":"--","app":"jsresourceloader","method":"GET","url":"\/index.php\/s\/TOKEN","message":"Could not find resource core$

I am also PHP 7.3.5. Since I started to generate some other errors after 7.3.5, I think that there is a problem with 7.3.5 and NC.


Nextcloud 16.0.1, CentOS 7.6, PHP 7.3.5, nginx 1.14.2

Same here …

Same here …

{“reqId”:“davaEGseHSIS4VDEBM7T”,“level”:3,“time”:“2019-05-23T13:21:57+00:00”,“remoteAddr”:“IP%ADDRESS”,“user”:"–",“app”:“jsresourceloader”,“method”:“GET”,“url”:"/index.php/s/DnBDney6yKqF77r",“message”:“Could not find resource core/vendor/marked/marked.min.js to load”,“userAgent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.169 Safari/537.36”,“version”:“16.0.1.1”,“id”:“5ce6b116c82c5”}

After update from 15.0.7 to 16.0.1
I get this error when someone visits shared link
Sharing works but in Logs I can see this message

[jsresourceloader] Error: Could not find resource core/vendor/marked/marked.min.js to load

GET /index.php/s/DnBDney6yKqF77r
from IP_Address at 2019-05-23T17:46:27+00:00

did someone found a solution?

Updating Talk from 6.0 to 6.0.1 seems to solve the problem for me.

I also have this error on a fresh install of nextcloud 16 on NGINX PHP7.3 redis

NOTE: I don’t have the app talk

aside of QOwnNotesAPI and Tasks apps, all others are officially official and up2date.

it seams to occur only when I navigate the web internet of nextcloud

{"reqId":"IxifD8YEfiP8Yebc3QkM","level":3,"time":"2019-06-11T19:52:33+00:00","remoteAddr":"192.168.1.55","user":"nimda","app":"jsresourceloader","method":"GET","url":"/settings/admin/workflow","message":"Could not find resource core/js/oc-backbone-webdav.js to load","userAgent":"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.169 Safari/537.36","version":"16.0.1.1","id":"5d00078eb5f86"}

might be related to an apps which use webdav like calendar or contact

ref: https://framagit.org/framasoft/framagenda-core/commit/9b3c4e8dc453a674c0f1aee8c60e9d7f24b34e49#15f2fe93fe2082868b69ddcefd6bcdc682bc7ff4

I’m having the same error with NC 16.0.1, any fix since ?

still no answer ?

ould not find resource js/oc-backbone-webdav.js to load is still alive

heres all the error i parses from my server:

[jsresourceloader] Error: Could not find resource js/oc-backbone-webdav.js to load
GET /index.php/apps/announcementcenter/

[jsresourceloader] Error: Could not find resource vendor/select2/select2.js to load
GET /index.php/apps/announcementcenter/

[cssresourceloader] Error: Could not find resource vendor/select2/select2.css to load
GET /index.php/apps/announcementcenter/

I am about to uninstall/re-install annoucement center to see if it fix the problem …

purging app and reinstall did not fixed the error !!