After migration from php 7.3 to 8.0, everything works except upgrading an app (upgrading **any** app)

Nextcloud version (eg, 20.0.5): 23.3
Operating system and version (eg, Ubuntu 20.04): FreeBSD 13.0-p11
Apache or nginx version (eg, Apache 2.4.25): nginx 1.20.2_9,2
PHP version (eg, 7.4): 8.0.17

The issue you are facing:

I upgraded the system from php 7.3 to 8.0 (as per the recommendation on upgrade from 22 to 23). After the upgrade, attempting to update an app would produce a box with the text “An error occured during the request. Unable to proceed.” and the system would then be in maintenance mode. Multiple tries don’t help.

Eventually, I also tried disabling the app (re-enabling same error) and removing the app (adding the app, same error … but not in maintenance mode).

I turned up the log, and got errors similar to this one:

{"reqId":"df1iHVYoEGinjmqXwFBh","level":0,"time":"2022-04-09T19:44:28+00:00","remoteAddr":"","user":"dgilbert","app":"fulltextsearch","method":"GET","url":"/ocs/v2.php/cloud/capabilities","message":"Could not determine if provider with id 'deck' was properly indexed because the corresponding provider-option could not be found. Make sure the ini
tial indexing process has been completed successfully.","userAgent":"Mozilla/5.0 (Android) Nextcloud-Talk v13.0.0","version":""}

Is this the first time you’ve seen this error? (Y/N): Yes

Steps to replicate it:

  1. Press update button on any app waiting for updates.

The output of your Nextcloud log in Admin > Logging:

I’ve put a sequence from the log into this pastebin. This was trying to reinstall the audio player app. Doesn’t complain about the index that is in the above line.

I’m not bundling up the nginx logs. No errors there, so nothing to report.

Try reporting directly to the dev.

Issues · Rello/audioplayer · GitHub

This has nothing to do with audioplayer itself. Gah. I strongly dislike when people skim and sort inappropriately.

As for my example, this replicates with Formus, Social sharing via email and talk.

Why those three? Those three need updates right now.

If I were to hazard a guess, something in the package management itself is busted.

Wow. There. I am empowered to move it back. That’s actually cool.

1 Like

Social is not supported since 21. It needs maintenance on multiple issues.

Forms was updated less than 48 hours ago with a new release, so try updating again.

every time I press update on any application, the same message appears. This is true for forms and for talk. Including right now.

To be even more exact, I have the log turned to 0 — which I read as max. The nextcloud log spits out the following one line when I click on update for forms:

{"reqId":"V1sZHAI3Cxisfg3tgllB","level":0,"time":"2022-04-10T06:12:02+00:00","remoteAddr":"","user":"Mark","app":"fulltextsearch","method":"GET","url":"/ocs/v1.php/cloud/capabilities?format=json","message":"Could not determine if provider with id 'deck' was properly indexed because the corresponding provider-option could not be found. Make sure the initial indexing process has been completed successfully.","userAgent":"Mozilla/5.0 (Macintosh) mirall/3.3.3git (build 7266) (Nextcloud, osx-19.6.0 ClientArchitecture: x86_64 OsArchitecture: x86_64)","version":""}

I read this all to be some snafu in the update. This nextcloud has been continuously updated from version to version since about the time nextcloud split from opencloud… so a long time. Could be cruft somewhere… could be corruption (but ZFS is pretty good at spotting corruption … and it sees none).

If disabling things fixed something, I’d start disabling things and then re-enabling them… but disabled things cannot be re-enabled — and I know that lots of people I care about use this thing… and while nobody has an SLA from me, they have an expectation.

In terms of classifying the use? My family, my gamer clan, my friends … etc … all use it. I’m trying to argue that using nextcloud is better than using google, facebook or whatever apple is. So in general, I need to keep things going to honestly give that advice. So… I’d like to fix this with a minimum of fuss.