After losing connection to SAN... unable to write files

So… basically the short notes are that I lost access to the mount point on a reboot (fstab had a typo). manually mounting fixed it temporarily. Rebooting again (this is also a cPanel server) brought the mount up properly, but though the user that is there (any web user where Nextcloud is installed) is able to touch any file within the structure, something within the web code isn’t talking, and I can’t see the issue in the logs. It just fails to write anything (via web/mobile. Windows simply does what it does, put files where we tell it, but they aren’t syncing).

I’ve gone through an update after all this to be sure it wasn’t something broken there, and still the same.

Interestingly, another instance on the same server has the same problem, so I don’t think it’s the install… I think it’s something in CentOS, but I’m just not sure what.

any ideas?

You are sure it is mounted with writing permissions. On CentOS, it’s always worth checking SELinux.

It was redis not starting. Fixed it. Thanks!!

Gord Hynes, from my Pixel