After i've installed Nextcloud i get internal server error

#1

I have installed Nextcloud and after i finished the web installer i have a internal server error
Nextcloud version 14.0.8
Operating system and version Raspbian 9
Apache version Apache 2.4.25
PHP version 7.3
The output of my config.php file in /var/www/html/nextcloud`

'<?php
$CONFIG = array (
‘instanceid’ => ‘ocd54jgjc6hh’,
‘passwordsalt’ => ‘xxxx’,
‘secret’ => ‘xxxxx’,
‘trusted_domains’ =>
array (
0 => ‘xxxx’,
),
‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘datadirectory’ => ‘/var/www/nextcloud/data’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘14.0.8.2’,
‘overwrite.cli.url’ => ‘http://xxxx/nextcloud’,
‘dbname’ => ‘nextcloud’,
‘dbhost’ => ‘localhost’,
‘dbport’ => ‘’,
‘dbtableprefix’ => ‘oc_’,
‘dbuser’ => ‘nextcloud’,
‘dbpassword’ => ‘xxxx’,
‘installed’ => true,
);

);


The output of my Apache log in `/var/log/error.log____`:

There is nothing with nextcloud

0 Likes

#2

Hey Lucki1000,

i had some internal server errors, when i was messing with php modules. Which ones do you have installed?

~$ php -m

Mine are currently:

[PHP Modules]
apcu
bz2
Core
ctype
curl
date
dom
exif
fileinfo
filter
gd
hash
iconv
imagick
intl
json
libxml
mbstring
mysqlnd
openssl
pcntl
pcre
PDO
pdo_mysql
posix
redis
Reflection
session
SimpleXML
SPL
standard
xml
xmlreader
xmlwriter
Zend OPcache
zip
zlib

[Zend Modules]
Zend OPcache

But my setup is different to yours (FreeBSD, nginx, etc.).

What php modules do you have installed?

0 Likes

#3

Hi
this modules i’ve installed:

apc
apcu
bcmath
bz2
calendar
Core
ctype
curl
date
dom
exif
fileinfo
filter
ftp
gd
gettext
hash
iconv
imagick
imap
intl
json
libxml
mbstring
mysqli
mysqlnd
openssl
pcntl
pcre
PDO
pdo_mysql
pdo_sqlite
Phar
posix
readline
Reflection
session
shmop
SimpleXML
sockets
sodium
SPL
sqlite3
standard
sysvmsg
sysvsem
sysvshm
tokenizer
wddx
xml
xmlreader
xmlwriter
xsl
Zend OPcache
zip
zlib

0 Likes

#4

hmmm…php doesn´t seem to be your problem.

could you check, if you have a nextcloud.log in your datadirectory (/var/www/nextcloud/data)?

if not, you might want to enable logging by adding the following lines to your config.php and restart your webserver:

“log_type” => “file”,
“logfile” => “nextcloud.log”,
“loglevel” => “2”,

if you see the logfile after the restart, reproduce the error and check the log for clues / post it here

0 Likes

#5

Yes, just there is my password in plain text in it.

0 Likes

#6

After few reboots It’s now going.

0 Likes

#7

Nice. :+1:

Was just wondering, if your mysql-server or another service was not up and running…reboot fixed that…i guess.

Edit:
@Lucki1000 You might want to add [SOLVED] to the title of this topic, so everybody knows, that it is fixed.

0 Likes

#8

See it’s already fixed, out of interest…

Could you be precise and provide a link to it or a name and version? There are more then one installers around!

What hardware and model?

0 Likes

#9

[Deleted comment]

0 Likes