After install, login screen loads with no form to login with

Hey all,

I’ve just installed the latest version (24.0.0) on to my Raspberry Pi. Install seems to work with the initial log in and set up and database. When I load the page to login for the first time, the form doesn’t load, however the rest of the page does load i.e. background logo etc… Happy to try certain things but I’m not sure where to to start as I’m a beginner when to SysAdmin things.


  • No form entry to login into Nextcloud

Actual Behaviour

  • Background and logo loads, but no login form

Expected Behaviour

  • As above, but with a login form

Addtional info

  • PHP v8.0
  • OS Raspian OS 64bit
  • Pi-Hole installed
  • Browser Chrome

Happy to provide more info, but assume I don’t know how to find it, so you may have to help with commands.
Thanks in Advance!

Have you entered all domains in config.php through which you access Nextcloud?


$ cat www/config/config.php | grep trusted_domains -A4
  'trusted_domains' => 
  array (
    0 => 'localhost',
    1 => '',
    2 => '',

I tried the command and there is `no such file or directory but I’m sure if this is the problem.

In which directory/path did you install Nextcloud?

It’s installed here:
However I cd to /var/www/html but not /var/www/html/nextcloud as it’s saying permission denied, even with sudo

Then your config.php is here:


Cool, thanks for this.

I ran sudo cat /var/www/html/nextcloud/config/config.php | grep trusted_domains -A4 and got the below

'trusted_domains' =>                                                            
  array (
    0 => '[pi internal IP address]',
  'datadirectory' => '/var/www/html/nextcloud/data',

Does this help?