After changing router and subdomain i don't reach my cloud from the outside

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 16.0.4
Operating system and version (eg, Ubuntu 17.04): Raspbian Buster (Linux Debian)
Apache or nginx version (eg, Apache 2.4.25): nginx
PHP version (eg, 7.1): 7.3

The issue you are facing:

I have fully installed my nextcloud on a raspberry pi with Raspbian Buster in a way that works. After that i have changed my subdomain and the location of my cloud. I have to installed that on a new flat and there i repeat all the nessecary stuff to set the configuration to reach my cloud from the outside:

  • Change the subdomain at the page of the domain-provider (
  • Set the DynDNS-Entry in my FritzBox 7590 (the old one was a 7430 with that all have worked)
  • Set the local ip of the raspberry to be static.
  • Enable Ports 443 for https and 80 for http (i route from http to https in my server-configuration, so that in both cases a user open a ssl-connection)

After i have complete the set up by following the above steps, i have tried to open my cloud via my new subdomain. I allowed alle known ips and domains in my nextcloud configuration for testin only. I have detected that i can open it via the local ip and via the global ip of the router. My Problem ist that also the way to open the cloud via the global address only (!) works if i open the connection within a local wlan connection. That means it doesn’t work from the outsite no matter if i use the local ip (192.168. …) oder the global one (100.66. …). May be it is important. I have also detect that in my Fritzbox i can see a DNS-Server ip that is different than the global ip (i call that one global!).

Would be really great if someone can help me to reach my cloud within the new location and the new equipment.

Is this the first time you’ve seen this error? (Y/N): Y


  • I have checked my ip at and it figured out that i have transmitted a false ip from my router to the domain-provider.
  • But (!) before i have changed my DynDNS configuration in my FritzBox 7590, i have transmitted the ip that i also receive if i check my ip via the brower. With that address it was also unable to reach my cloud from the outside.
  • After a research i have detected, that two ip’s have private character. The 192.168. … and also the 100.66. … as i have read at a german wikipedia site .
  • Ok, i am confused. I have different ip’s i know. I have a static local one for my raspi (192.168. …), a special provider internal one (100.66. …) and a external one (185.78. …).
  • I have detected that the router is connected to an ISDN VoIP Telephone Adapter. May be i have to configure this one to forward the 185.78. … to my 100.66. … and the to 192.168. … It’s an product of the “Stadtwerke xy”.

It looks like your new provider is using a carrier grade NAT. It means that many customers share the same public ipv4 address. So I suppose you need an option to get your own dedicated ipv4 address.

Ways around:

  • use some sort of VPN and connect to an outside provider which can give you an ipv4 (generally paid)
  • use ipv6, I hope your provider provides you with ipv6, if all your clients have ipv6 as well this could be enough (it’s not great if you want to be able to share content with somebody without ipv6)
  • get an option for a real dual-stack connection (public ipv4 & ipv6)