Admin password works for logging in, but not for enabling apps

Hey all,

I was using 11.0.1 without any issues, but since upgrading to v11.0.3 (and still since upgrading to v12), I have a weird problem where my username and password logs me in to Nextcloud, but if I’m asked to use it anywhere else (such as activating an app) I’m told that it’s the wrong password.

I’ve made sure I’m added to the admin group via occ. I get the same error if I make a new user and make them an admin via occ. Oddly enough, as well as the admin group, there also seems to be a group called admins which I can’t add myself to or delete. I just get an error “Can’t delete group admins”. Not sure if this is related.

Nextcloud version:
Operating system and version: Debian 8
Nginx version: Nginx 1.6.2
PHP version: 5.6.3
Is this the first time you’ve seen this error?: Yes

Can you reliably replicate it? (If so, please outline steps):
ALways. Just try to do any action which asks for the adminisrator password, other than logging in, eg enabling a package disabled in the upgrade.

The issue you are facing:
Password is no longer accepted other than for login.

The output of your Nextcloud log in Admin > Logging:

I see the following errors / warnings:
Error PHP Call to a member function getCache() on null at /var/www/nextcloud/apps/files_sharing/lib/Cache.php#69 2017-05-22T09:15:01-0400
Warning core Login failed: ‘user’ (Remote IP: ‘’) 2017-05-19T09:03:28-0400
Warning user_ldap Bind failed: 49: Invalid credentials 2017-05-19T09:03:28-0400
Error PHP Call to a member function getCache() on null at /var/www/nextcloud/apps/files_sharing/lib/Cache.php#69 2017-05-19T08:15:02-0400
Warning core Login failed: ‘user’ (Remote IP: ‘’) 2017-05-19T06:35:53-0400
Warning user_ldap Bind failed: 49: Invalid credentials 2017-05-19T06:35:53-0400
Warning core Exception when running cache gc: This request is not allowed to access the filesystem

The output of your config.php file:

<?php $CONFIG = array ( 'passwordsalt' => 'XXXXXXXXXXXXXXXXXXXXXXX', 'secret' => 'XXXXXXXXXXXXXXXXXXX', 'trusted_domains' => array ( 0 => 'localhost', 1 => '', ), 'datadirectory' => '/path/to/nextcloud/data', 'overwrite.cli.url' => '', 'dbtype' => 'mysql', 'version' => '', 'dbname' => 'nextcloud', 'dbhost' => 'localhost', 'dbtableprefix' => 'nc_', 'dbuser' => 'nextcloud', 'dbpassword' => 'notmyrealpassword', 'logtimezone' => 'UTC', 'installed' => true, 'instanceid' => 'notmyinstanceid', 'ldapIgnoreNamingRules' => false, 'memcache.local' => '\\OC\\Memcache\\APCu', 'memcache.locking' => '\\OC\\Memcache\\APC', 'theme' => '', 'loglevel' => 2, 'maintenance' => false, 'appstore.experimental.enabled' => true, 'mail_from_address' => 'me', 'mail_smtpmode' => 'php', 'mail_domain' => '', 'updatechecker' => true, 'logout_url' => '', 'htaccess.RewriteBase' => '/', 'updater.server.url' => '', '' => 'stable', 'preview_libreoffice_path' => '/usr/lib/libreoffice/program/soffice', 'ldapProviderFactory' => '\\OCA\\User_LDAP\\LDAPProviderFactory', 'app.mail.imaplog.enabled' => true, 'app.mail.imap.timeout' => 60, ); **The output of your Apache/nginx/system log in `/var/log/____`:** Nothing in the last couple of days since I upgraded.

Gah. Just discovered this seems to be caused by some plugin I have in Firefox. In Chromium, no problem. In firefox with all extensions disabled, no problem. Firefox with extensions. Problem.