Admin page - logging - not loading, only spinner

#1
Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version 16:
Operating system and version ubuntu 18.04:
Apache or nginx version apache2 through reverse proxy:
PHP version 7.3:

The issue you are facing:
when I go to the admin page and select the ‘logging’ section I am now faced with the loading spinner that doesn’t stop and no logs appear

Is this the first time you’ve seen this error? n: happening whilst I have tried to find a resolution, but haven’t been able to.

Steps to replicate it:

  1. goto admin page
  2. goto logging

The output of your Nextcloud log in Admin > Logging:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => '',
  'passwordsalt' => '',
  'secret' => '',
  'trusted_domains' => 
  array (
    0 => '',
    1 => '',
  ),
  'datadirectory' => '/var/www/nextcloud/data',
  'overwrite.cli.url' => '',
  'htaccess.RewriteBase' => '/nextcloud',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => '',
  'dbhost' => '',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '',
  'dbpassword' => '',
  'installed' => true,
  'trusted_proxies' => 
  array (
    0 => '',
  ),
  'overwriteprotocol' => 'https',
  'forwarded_for_headers' => array('HTTP_X_FORWARDED', 'HTTP_FORWARDED_FOR'),
  'maintenance' => false,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => 'true',
  'redis' => 
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
    'timeout' => 0.0,
  ),
  'theme' => '',
  'loglevel' => 2,
  'force_language' => 'en',
  'force_locale' => 'en_GB',
  'remember_login_cookie_lifetime' => 0,
  'session_lifetime' => 28800,
  'check_for_working_htaccess' => true,
  'log_rotate_size' => 26214400,
  'mail_from_address' => '',
  'mail_smtpmode' => '',
  'mail_domain' => '',
  'mail_smtphost' => '',
  'mail_smtpport' => '',
  'mail_smtpauth' => 1,
  'mail_smtpname' => '',
  'mail_smtppassword' => '',
  'onlyoffice' => 
  array (
    'verify_peer_off' => true,
    'jwt_secret' => '',
    'jwt_header' => 'Authorization',
  ),
  'app_install_overwrite' => 
  array (
    0 => 'end_to_end_encryption',
    1 => 'groupfolders',
    2 => 'ocsms',
    3 => 'calendar',
    4 => 'mail',
  ),
);

The output of your Apache/nginx/system log in /var/log/____:

error.log

[Thu Jun 13 06:25:25.221571 2019] [mpm_prefork:notice] [pid 1363] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Thu Jun 13 06:25:25.221673 2019] [core:notice] [pid 1363] AH00094: Command line: '/usr/sbin/apache2'
[Thu Jun 13 08:22:17.799089 2019] [autoindex:error] [pid 10252] [client 192.168.1.5:50100] AH01276: Cannot serve directory /var/www/nextcloud/: No matching DirectoryIndex (none) found, and server-generated directory index forbidden by Options directive
[Thu Jun 13 15:07:19.779445 2019] [autoindex:error] [pid 10230] [client 192.168.1.5:43748] AH01276: Cannot serve directory /var/www/nextcloud/: No matching DirectoryIndex (none) found, and server-generated directory index forbidden by Options directive
[Thu Jun 13 16:01:29.528605 2019] [autoindex:error] [pid 21578] [client 192.168.1.5:48910] AH01276: Cannot serve directory /var/www/nextcloud/: No matching DirectoryIndex (none) found, and server-generated directory index forbidden by Options directive
[Thu Jun 13 20:03:02.671531 2019] [autoindex:error] [pid 24450] [client 192.168.1.5:51892] AH01276: Cannot serve directory /var/www/nextcloud/: No matching DirectoryIndex (none) found, and server-generated directory index forbidden by Options directive
[Thu Jun 13 20:43:21.073567 2019] [mpm_prefork:notice] [pid 1363] AH00169: caught SIGTERM, shutting down
[Thu Jun 13 20:43:22.359105 2019] [mpm_prefork:notice] [pid 27180] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Thu Jun 13 20:43:22.359291 2019] [core:notice] [pid 27180] AH00094: Command line: '/usr/sbin/apache2'

other_vhost_access.log

127.0.0.1:80 192.168.1.X - [13/Jun/2019:21:30:03 +0000] "PROPFIND /nextcloud/remote.php/dav/files// HTTP/1.1" 207 1187 "-" "Mozilla/5.0 (Linux) mirall/2.5.2git (Nextcloud)"
127.0.0.1:80 192.168.1.X - [13/Jun/2019:21:30:14 +0000] "PROPFIND /nextcloud/remote.php/dav/files/ HTTP/1.1" 207 1186 "-" "Mozilla/5.0 (Linux) mirall/2.5.2git (Nextcloud)"
127.0.0.1:80 192.168.1. - - [13/Jun/2019:21:30:19 +0000] "GET /nextcloud/ocs/v2.php/apps/notifications/api/v2/notifications HTTP/1.1" 200 776 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0"
127.0.0.1:80 192.168.1.X -  [13/Jun/2019:21:30:35 +0000] "PROPFIND /nextcloud/remote.php/dav/files// HTTP/1.1" 207 1187 "-" "Mozilla/5.0 (Linux) mirall/2.5.2git (Nextcloud)"
127.0.0.1:80 192.168.1.X -  [13/Jun/2019:21:30:44 +0000] "PROPFIND /nextcloud/remote.php/dav/files// HTTP/1.1" 207 1186 "-" "Mozilla/5.0 (Linux) mirall/2.5.2git (Nextcloud)"
127.0.0.1:80 192.168.1.X - - [13/Jun/2019:21:30:49 +0000] "GET /nextcloud/ocs/v2.php/apps/notifications/api/v2/notifications HTTP/1.1" 200 776 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0"
#2

A few questions…

Does the user www-data own /var/www/nextcloud/ and all files and subdirectories? If no, fix this (sudo chown -R www-data:www-data /var/www/nextcloud/), restart apache and try again.

If ownership is correct, or the problem still exists after fixing ownership, please provide:

the output of apachectl -M

The contents of the Apache conf file for your Nextcloud site (please redact any sensitive info)

Have you modified the default .htaccess file that shipped with Nextcloud?

#3

Hi

Thank you for your assistance.

All the files a re owned by ‘www-data’

The output from apachectl -M is:

AH00557: apache2: apr_sockaddr_info_get() failed for cloud
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive globally to suppress this message
Loaded Modules:
 core_module (static)
 so_module (static)
 watchdog_module (static)
 http_module (static)
 log_config_module (static)
 logio_module (static)
 version_module (static)
 unixd_module (static)
 access_compat_module (shared)
 alias_module (shared)
 auth_basic_module (shared)
 authn_core_module (shared)
 authn_file_module (shared)
 authz_core_module (shared)
 authz_host_module (shared)
 authz_user_module (shared)
 autoindex_module (shared)
 deflate_module (shared)
 dir_module (shared)
 env_module (shared)
 filter_module (shared)
 headers_module (shared)
 mime_module (shared)
 mpm_prefork_module (shared)
 negotiation_module (shared)
 php7_module (shared)
 proxy_module (shared)
 proxy_fcgi_module (shared)
 rewrite_module (shared)
 setenvif_module (shared)
 status_module (shared)

My apache conf file is

Alias /nextcloud "/var/www/nextcloud/"

<Directory /var/www/nextcloud/>
  Options +FollowSymlinks
  AllowOverride All

 <IfModule mod_dav.c>
  Dav off
 </IfModule>

 <IfModule mod_headers.c>
  Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains"
 </IfModule>

 SetEnv HOME /var/www/nextcloud
 SetEnv HTTP_HOME /var/www/nextcloud
 Requestheader set X-Forwarded-Proto "https"
</Directory>

The site is behind a reverse proxy.

I haven’t touched the .htaccess file, it is as it was installed, i hope:

<IfModule mod_headers.c>
  <IfModule mod_setenvif.c>
    <IfModule mod_fcgid.c>
       SetEnvIfNoCase ^Authorization$ "(.+)" XAUTHORIZATION=$1
       RequestHeader set XAuthorization %{XAUTHORIZATION}e env=XAUTHORIZATION
    </IfModule>
    <IfModule mod_proxy_fcgi.c>
       SetEnvIfNoCase Authorization "(.+)" HTTP_AUTHORIZATION=$1
    </IfModule>
  </IfModule>

  <IfModule mod_env.c>
    # Add security and privacy related headers
    Header set X-Content-Type-Options "nosniff"
    Header set X-XSS-Protection "1; mode=block"
    Header set X-Robots-Tag "none"
    Header set X-Download-Options "noopen"
    Header set X-Permitted-Cross-Domain-Policies "none"
    Header set Referrer-Policy "no-referrer"
    SetEnv modHeadersAvailable true
  </IfModule>

  # Add cache control for static resources
  <FilesMatch "\.(css|js|svg|gif)$">
    Header set Cache-Control "max-age=15778463"
  </FilesMatch>

  # Let browsers cache WOFF files for a week
  <FilesMatch "\.woff2?$">
    Header set Cache-Control "max-age=604800"
  </FilesMatch>
</IfModule>
<IfModule mod_php7.c>
  php_value mbstring.func_overload 0
  php_value default_charset 'UTF-8'
  php_value output_buffering 0
  <IfModule mod_env.c>
    SetEnv htaccessWorking true
  </IfModule>
</IfModule>
<IfModule mod_rewrite.c>
  RewriteEngine on
  RewriteCond %{HTTP_USER_AGENT}  DavClnt
  RewriteRule ^$         /remote.php/webdav/          [L,R=302]
  RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
  RewriteRule ^\.well-known/host-meta /public.php?service=host-meta [QSA,L]
  RewriteRule ^\.well-known/host-meta\.json /public.php?service=host-meta-json [QSA,L]
  RewriteRule ^\.well-known/webfinger /public.php?service=webfinger [QSA,L]
  RewriteRule ^\.well-known/carddav /remote.php/dav/ [R=301,L]
  RewriteRule ^\.well-known/caldav /remote.php/dav/ [R=301,L]
  RewriteRule ^remote/(.*) remote.php [QSA,L]
  RewriteRule ^(?:build|tests|config|lib|3rdparty|templates)/.* - [R=404,L]
  RewriteCond %{REQUEST_URI} !^/\.well-known/(acme-challenge|pki-validation)/.*
  RewriteRule ^(?:\.|autotest|occ|issue|indie|db_|console).* - [R=404,L]
</IfModule>
<IfModule mod_mime.c>
  AddType image/svg+xml svg svgz
  AddEncoding gzip svgz
</IfModule>
<IfModule mod_dir.c>
  DirectoryIndex index.php index.html
</IfModule>
AddDefaultCharset utf-8
Options -Indexes
<IfModule pagespeed_module>
  ModPagespeed Off
</IfModule>
#### DO NOT CHANGE ANYTHING ABOVE THIS LINE ####

ErrorDocument 403 /nextcloud/
ErrorDocument 404 /nextcloud/
<IfModule mod_rewrite.c>
  Options -MultiViews
  RewriteRule ^core/js/oc.js$ index.php [PT,E=PATH_INFO:$1]
  RewriteRule ^core/preview.png$ index.php [PT,E=PATH_INFO:$1]
  RewriteCond %{REQUEST_FILENAME} !\.(css|js|svg|gif|png|html|ttf|woff2?|ico|jpg|jpeg)$
  RewriteCond %{REQUEST_FILENAME} !core/img/favicon.ico$
  RewriteCond %{REQUEST_FILENAME} !core/img/manifest.json$
  RewriteCond %{REQUEST_FILENAME} !/remote.php
  RewriteCond %{REQUEST_FILENAME} !/public.php
  RewriteCond %{REQUEST_FILENAME} !/cron.php
  RewriteCond %{REQUEST_FILENAME} !/core/ajax/update.php
  RewriteCond %{REQUEST_FILENAME} !/status.php
  RewriteCond %{REQUEST_FILENAME} !/ocs/v1.php
  RewriteCond %{REQUEST_FILENAME} !/ocs/v2.php
  RewriteCond %{REQUEST_FILENAME} !/robots.txt
  RewriteCond %{REQUEST_FILENAME} !/updater/
  RewriteCond %{REQUEST_FILENAME} !/ocs-provider/
  RewriteCond %{REQUEST_FILENAME} !/ocm-provider/
  RewriteCond %{REQUEST_URI} !^/\.well-known/(acme-challenge|pki-validation)/.*
  RewriteRule . index.php [PT,E=PATH_INFO:$1]
  RewriteBase /nextcloud
  <IfModule mod_env.c>
    SetEnv front_controller_active true
    <IfModule mod_dir.c>
      DirectorySlash off
    </IfModule>
  </IfModule>
</IfModule>

#4

Alrighty, well you seem to be attempting to serve HTTPS based on your apache conf, but you don’t have the Apache SSL module enabled. Let’s try this:

  1. Load apache SSL module:
    sudo a2enmod ssl

  2. Restart Apache and re-test. If still no dice, try a known working Apache conf (mine):

https://pastebin.com/cyZXDMCV

Just save that as “test.conf” or something, a2dissite your current one and a2ensite this one. You’ll need to edit the custom info like FQDN and stuff, and insert the Requestheader set X-Forwarded-Proto "https" line for your proxy. Your conf file is missing some items, I’d suggest giving my template a try regardless.

edit: When you try to access the Logging page, when/if it fails, go check out your apache log, probably /var/log/apache2/other_vhosts_access.log…look for a line like this near the bottom:

[16/Jun/2019:16:26:48 +0000] "GET /apps/logreader/css/app.css?v=5337810b-5 HTTP/1.1" 200 1054 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.90 Safari/537.36"

and look for any errors following it.

#5

Quick question

It is the proxy that runs the https and it is normal http that runs to the container, do I still need to enable the apache ssl module on the container?

#6

I’m not familiar enough with that configuration to give you an intelligent answer. In the interim let’s try the log route (I should have done that in the first place).

#7
Cloud.MyDomain.com:80 192.168.1.5 - - [17/Jun/2019:19:20:34 +0000] "GET /apps/logreader/settings HTTP/1.1" 200 1270 "-" "Mozilla/5.0 (Linux; Android 9; Nokia 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.89 Mobile Safari/537.36"

No errors below this and nothing in the other logs at that time.