Admin account lost file icons in web interface and can't upload files

Last night I thought it would be a good idea to backup my entire server as an .iso since everything was going smoothly for a week or so now…

I used CloneZilla, and backed up install to a flash drive.

Everything should have remained working since all I did was copy the whole drive as a backup.

When I tried to log into Nextcloud again it gave me an error about the data directory not existing.

I have a 15TB ZFS pool called “MyZFSPool” which has my data directory. For some reason the backup messed with the ZFS pool. When I tried listing the zpools it said that none were found. When I tried remaking the pool it said that these drives may already be associated with a pool called ‘MyZFSPool’. I went ahead and just added -f to the command to force it to remake the pool, I then got a different error when trying to log into Nextcloud, saying I had to add a ‘.ocdata’ blank file to the directory. So I added it.

Everything worked! I could log back into a regular user account with no errors, and the test files that I had uploaded previously were all still there, meaning that the zpool wasn’t wiped or anything like that.

Log into the admin account and for some reason all the icons are missing.

Checked the logging tab in the admin settings and this is what’s there. I can tell it has something to do with the ZFS pool still but its a bit above my head to know where to go from here.

If anyone could tell me how to fix this, and why making a simple backup of the working configuration broke the working configuration, that would be awesome!


I just tried to upload something to the server and it said ‘internal server error’ and now these are the logs.