Activity mail are not being sent

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 17.0.2.1
Operating system and version (eg, Ubuntu 17.04): Ubuntu 18.04
Apache or nginx version (eg, Apache 2.4.25): nginx 1.14.0
PHP version (eg, 7.1): 7.2.24-0ubuntu0.18.04.2

The issue you are facing: Activities notifications are not being sent after reinstallment. I’ve confirmed that SMTP config is correct, I’ve selected appropriate options in Settings->Activity tab, and even Nextcloud itself recognizes file creation since it is shown on activity stream. But there are no Nextcloud log which ‘tries’ to send mail on cron even if loglevel is 0, and also no access or error log exists on mailserver-side log.

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:

PASTE HERE

Log only shows ‘Login failed’ warning, so did not paste it.
The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

PASTE HERE
<?php $CONFIG = array ( 'instanceid' => , 'passwordsalt' => , 'secret' => , 'trusted_domains' => array ( 0 => , ), 'datadirectory' => '/var/www/nextcloud/data', 'dbtype' => 'mysql', 'version' => '17.0.2.1', 'overwrite.cli.url' => , 'dbname' => 'nextcloud', 'dbhost' => , 'dbport' => '', 'dbtableprefix' => 'oc_', 'mysql.utf8mb4' => true, 'dbuser' => 'nextcloud', 'dbpassword' => , 'installed' => true, 'maintenance' => false, 'theme' => '', 'log_type' => 'syslog', 'log_level' => 0, 'memcache.local' => '\\OC\\Memcache\\Redis', 'memcache.distributed' => '\\OC\\Memcache\\Redis', 'redis' => array ( 'host' => '/var/run/redis/redis-server.sock', 'port' => 0, 'dbindex' => 0, ), 'mail_smtpmode' => 'smtp', 'mail_smtpsecure' => 'tls', 'mail_sendmailmode' => 'smtp', 'mail_from_address' => , 'mail_domain' => , 'mail_smtpauthtype' => 'LOGIN', 'mail_smtpauth' => 1, 'mail_smtphost' => , 'mail_smtpport' => '587', 'mail_smtpname' => , 'mail_smtppassword' => , ); The output of your Apache/nginx/system log in `/var/log/____`: ``` PASTE HERE ``` Contains access logs only, without any useful info for this case, so did not paste it