Activities in file details not working (or shown) anymore

Hello everyone,

first of: There are more detailed information in the section below.

For starters we are having lots of problems with the Activity in the detail tab of files. Our main (or key) users did use this a lot and relied on the correct display of the activity of files which don’t show any detail for a while now (probably since version 20 - it worked partially in 19.0.10 which we also tested). Those users swear that this worked in former versions of Nextcloud. You could see all activity information of for example other users who did rename, uploaded a new version or commented on a file. This was a huge benefit which has now been not working anymore. I provided two screenshots which shows two files from two different test users on our test system. Those users uploaded one file each and renamed the file of the other test user. Even the user who uploaded its own file don’t see anyof its own activity.

This is happening in “regular” folders, group folders or pretty much anywhere.

Just to clarify I am not talking about the “main Activity” info which can be viewed at the top for each user. I am talking about the file detail information which is shown for each file if you click on details.

So anyone experienced the same issues or have an idea on how to fix it?

Hope the upcoming information helps to identify the problem.

Thanks.


Nextcloud version (eg, 20.0.5): 21.0.1 (pretty much since version 20)
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04.2 LTS
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.41 (Ubuntu)
PHP version (eg, 7.4): 7.4.3

The issue you are facing:
The detail view of a file don’t show any Activities. We know for a fact that it worked in previous (NC 19.x) before even - and this is the important part - from ANY user who made changes or commented on the file before not only oneself.

The test we made was create two test users “Testuser1” and “Testuser2” which created one file each in a folder. We renamed the file from “Testuser1” with the “Testuser2” (permissions are set accordingly on that folder the files are in) and vice versa. Renaming works perfectly but no activity is shown in the detail tab. You can see this in screenshots provided.

Is this the first time you’ve seen this error? (Y/N): N (exists since version 20)

Steps to replicate it:

  1. Create files
  2. Modify files by which user whatever
  3. Check Activity tab in detail view

The output of your Nextcloud log in Admin > Logging:

No output during the time of tests

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => 'xxx',
  'passwordsalt' => 'yyy',
  'secret' => 'zzz',
  'trusted_domains' =>
  array (
    0 => '[OUR TEST SYSTEM]',
  ),
  'datadirectory' => '/home/data',
  'dbtype' => 'mysql',
  'version' => '21.0.1.1',
  'overwrite.cli.url' => 'http://[OUR TEST SYSTEM]',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextclouduser',
  'dbpassword' => 'abc',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_smtphost' => '[OUR MAIL SERVER]',
  'mail_smtpport' => '25',
  'mail_from_address' => '[A DOMAIN USER]',
  'mail_domain' => '[OUR DOMAIN]',
  'maintenance' => false,
  'loglevel' => '3',
  'theme' => '',
  'updater.release.channel' => 'stable',
  'default_phone_region' => 'DE',
  'app_install_overwrite' =>
  array (
    0 => 'spreed',
  ),
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => 'true',
  'redis' =>
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
    'timeout' => 0.0,
  ),
);