Accessing to a samba server Where is External Storage?

Hello everyone,

I’m new on this forum, my name is Jean-Philippe from France, Jura.
I’m a long time Linux user (and sometime code writer).

I’ve installed nextcloud on a Debian Jessie server and I would like that my users can access (ro) to files on a samba server (OpenMediaVault), so I read a lot of docs, I installed php5-libsmbclient, the external user support in NextCloud,
but I cant configure it, I’ve searched for few days and I cannot find where is the EXTERNAL STORAGE option that the doc talk about.

If someone could help please ?

Thanks

Jean-Philippe

On my Nextcloud 11 server, installed from the zip file as described on the Install page, the “External storage support” app is installed and enabled by default.

(I originally installed Nextcloud from git, but found that many of the “standard” features were not installed. After struggling to enable the 2nd or 3rd standard feature I re-installed from zip, after which everything has worked as documented)

To create an SMB mount point, I did this:

  • login as an admin
  • click my name at the top right and select ‘admin’
  • select ‘External storages’ on the left
  • enter a name for the external storage location (personally, I begin all external storage mountpoints with “_” so that they sort to the top of the file list, like this: “_Data”)
  • Select ‘SMB / CIFS’ from the ‘Add storage’ pull-down
  • Enter the requested server and login information

When the information is correct the status indicator at the left will become a green dot.

On the same admin screen is a check-box to “Allow users to mount external storage”. If you check that box you can allow users to create their own connections to external storage using the protocols you select from this list:

  • FTP
  • WebDAV
  • Nextcloud
  • SFTP
  • Amazon S3
  • Dropbox
  • Google Drive
  • OpenStack Object Storage
  • SMB / CIFS

Hi Jean-Philippe,

I have the same setup working. I’m sure I can get this working fo you. I have a few questions. Have you got samba shares working on Jessie. On nextcloud can you log in as Admin and click on files, top left. You should get a list of options, one being apps. Let me know if you don’t see that option.

Hello everyone,

Thanks for your replys
Finaly, I reinstall all from the beginning (before I removed the nextcloud database) following the doc as mmccarn did and now I have the external storage :slight_smile:
but it is still not working, I don’t understand if I must or not configure mount points from the Linux shell before configuring in Nextcloud. That is not clear for me.

I must say that I had to activate the 2 modules External storage support and External user support.
Jean-Philippe

I just forgot to say that if I mount samba shares manually, I can accès to my samba server from the command line.

Hello again,

It works fine, I helped me with the samba server syslog to see what was wrong, it was just the field subfolder that I had to let blank in my case.

Thanks a lot

For those that have the same problem, the samba server must not be already mounted from the Linux system under nextcloud.

Jean-Philippe