Accessing appstore fails with curl error 49: Couldn't parse 'apps.nextcloud.com:80:'

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 23.0.3.2
Operating system and version (eg, Ubuntu 20.04): Arch Linux
Apache or nginx version (eg, Apache 2.4.25): Nginx 1.20.2
PHP version (eg, 7.4): 8.1.6

The issue you are facing:

Can’t see apps on the AppStore.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Login as Admin
  2. Go to any page that should list appstore apps
  3. Frown at the non-existent list of uninstalled apps.

The output of your Nextcloud log in Admin > Logging:

[appstoreFetcher] Warning: cURL error 49: Couldn't parse CURLOPT_RESOLVE entry 'apps.nextcloud.com:80:' (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for https://apps.nextcloud.com/api/v1/apps.json

GET /settings/apps/list
from **router ip** by admin at 2022-05-20T14:28:53+00:00

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'datadirectory' => '/var/lib/nextcloud/data',
  'logfile' => '/var/log/nextcloud/nextcloud.log',
  'apps_paths' => 
  array (
    0 => 
    array (
      'path' => '/usr/share/webapps/nextcloud/apps',
      'url' => '/apps',
      'writable' => false,
    ),
    1 => 
    array (
      'path' => '/var/lib/nextcloud/apps',
      'url' => '/wapps',
      'writable' => true,
    ),
  ),
  'trusted_domains' => 
  array (
	  0 => 'my.website.domain',
  ),
  'overwrite.cli.url' => 'https://my.website.domain/',
  'htaccess.RewriteBase' => '/',
  'appstoreenabled' => true,
  'passwordsalt' => 'salty',
  'secret' => 'secrets_dreams',
  'dbtype' => 'pgsql',
  'version' => '23.0.3.2',
  'dbname' => 'nextcloud',
  'dbhost' => '/run/postgresql',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'nextcloud',
  'dbpassword' => 'password',
  'installed' => true,
  'instanceid' => 'ocoqz23aixtv',
  'memcache.local' => '\OC\Memcache\Redis',
  'memcache.distributed' => '\OC\Memcache\Redis',
  'memcache.locking' => '\OC\Memcache\Redis',
  'redis' => [
    'host'	=> '/run/redis/redis-server.sock',
    'port'	=> 0,
    'dbindex'	=> 0,
    'timeout'	=> 1.5,
  ],
);

Turns out I was focused on the wrong error. There was another error pointing to DNS issues and it turns out I didn’t have resolv.conf properly symlinked to work with systemd-resolved. Once I fixed that, it works fine.