Access via App on Android and iOS not orking

Hi guys,

Very strange Issue here.
We have an NC running on a Ubuntu 22.04 LTS, installed after the standard-instructions with maria db etc.
Runs with php 8.1

Usage via Webbrowser and Windows-Desktop-App is working as designed, but access via Mobile App (Android and iOS) ist not possible.
Im able to login but after this step i see an empty folder.
It just shows’ No Data available’ (‘Keine Daten vorhanden’ because we use it in German)
If i click on Activities i get the Error ‘Operation finished with HTTP Status code 401(fail)’
While trying this i get following error in the NC-log:
[core] Warning: Login failed: ‘user-name’ (Remote IP: ‘IP of the reverse proxy’)
Credentials of this user are correct and working via Webbrowser.
Error happens with all users.

Do you have an idea how to fix this? I dont get whats the issue and i cant find anybody that has the same behaviour.

I tried updating to the newest stable NC - no change i tried to update to the 27.0.0 RC of the beta - Issue is still there