Access Nextcloud Box using SSH from OS X

Hi all.

I’ve attempted to SSH into the NextCloud Box. I use sudo nextcloud.local -i -u ubuntu (ubuntu is the default login name for snap I guess because it works in a local session) and I enter the password I set for it which ALSO works in the local session. The password is rejected, so either SSH connections are not accepted, or else there is another user like root that it is expecting, or else I have to enable ssh access for the ubuntu user (which imho should already be set up and enabled because why would I want to keep a monitor and keyboard hooked up to a cloud box in another site).

Any ideas how to proceed? I want to be able to remotely access this box from my Mac on the LAN. Seems like a simple thing to do.

Hi, being no Mac user, I hope this still might help: Try if this in your terminal works: ssh ubuntu@nextcloud.local
Might be you need to check what IP adress the NC box has (instead of nextcloud.local).
If you log in to the box with the monitor and keyboard connected, do ifconfig, the second line shows “inet addr:192.168.nnn.nnn”, then on the Mac: ssh ubuntu@192.168.nnn.nnn

That is interesting that nextcloud is available as a snap. Only ever installed it on a server manually. It’s sad that posts like this go for a month without a reply so will try to help you.

If understand you correctly Nextcloud is installed as a snap. A snap is supposed to be totally self-contained so don’t think that SSH would be installed with the snap, only Apache and MySQL would logically be included in the snap. So to access nextcloud installed as snap via SSH am thinking one would access the system via SSH that the Nextcloud snap is installed on and then browse within the /home/users/.snap folder (think that snap data is stored in /home/user/.snap).

So if you still want to make this happen and are following me what operating system did you install the snap on?

Oh I figured it out myself. I connected a keyboard and monitor, found out what the default account and password is, ran sudo -i to switch to root account, then drilled down into the folders until I found the errant folder. I was then able to delete the orphaned folder containing all the files without incident.

I think the problem with Linux in terminal mode is that the people who work with it every day know the basics of how to get around in it, so often help provided is done with the assumption that the person being helped already know the same basic principles. Thankfully I have experience in the OS X terminal, so it wasn’t completely foreign, but finding the default admin account for ubuntu and the default password took some degree of googling.

I think Nextcloud is pretty cool, but there needs to be a way to switch between Client As Master and Server As Master as was discussed on other threads, because different scenarios can be demonstrated where there can be permanent loss of data, and there seems to be some resistance to having it any other way, although there is an effort to modify this somewhat.

Bob S

Hi all, hi @slylabs13 ,

I am totally new to linux and the terminal. This thread seemed to me the closest to my problem and @slylabs13 is using a mac as I am.
So here is my problem: after setting up my ubuntu one account and my NC box with a pi 3 the installation goes well until the following is displayed on the connected monitor:
Ubuntu Core 16 on (tty1)

The host key fingerprints are:

   RSA          SHA256:xxx
   DSA          SHA256:xxx
   ECDSA     SHA256:xxx
   ED25519   SHA256:xxx

To login:

   ssh <myUbuntOneUsername>

Personalize your account at

and I don’t know how to go on I tried several passwords each several times but it seems to me I am not using the right combination of user and password for the first time.

So this is where I am stuck, and I need some ideas how to proceed.

If this not the right place for my question please point me in to the right one.

If you are trying to delete a folder, you will need root. The default root password is ubuntu if I am not entirely forgetful. If you are trying to change your password, then the web interface or the client software should do it. You can change your password in the terminal by logging in as root then entering sudo passwd . It will ask for a new password twice and will not echo what you type so type carefully.

Bob S

Also, you need to make sure you enable SSH. It looks like from the response that it is not asking for a password it is saying you need to use the web interface to log in as the administrator first, then create the account there.

Bob S