About the built-in version of nginx in Collabora

I’m trying the built-in CODE, but nginx doesn’t know how to configure it.


location ~ ^\/(?:index|remote|public|cron|core\/ajax\/update|status|ocs\/v[12]|updater\/.+|oc[ms]-provider\/.+|.+\/richdocumentscode\/proxy)\.php(?:$|\/) {
    fastcgi_split_path_info ^(.+?\.php)(\/.*|)$;
    set $path_info $fastcgi_path_info;
    try_files $fastcgi_script_name =404;
    include fastcgi_params;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    fastcgi_param PATH_INFO $path_info;
    fastcgi_param HTTPS on;
    # Avoid sending the security headers twice
    fastcgi_param modHeadersAvailable true;
    # Enable pretty urls
    fastcgi_param front_controller_active true;
    fastcgi_pass php-handler;
    fastcgi_intercept_errors on;
    fastcgi_request_buffering off;


location ~ ^\/nextcloud\/(?:index|remote|public|cron|core\/ajax\/update|status|ocs\/v[12]|updater\/.+|oc[ms]-provider\/.+|.+\/richdocumentscode\/proxy)\.php(?:$|\/) {

Can I do this by rewriting the location part above(default)?
I couldn’t do it with that. I then tried “location ~ ^/(?:index…”, minus the “^/nextcloud/”. I still can’t connect to the built-in code.

How should I describe nginx?
I put NC in the webroot, not in a subdirectory.

Nextcloud 19.0.0, Nginx 1.16.1, PHP 7.3.18

Not related to this topic, but please tell me more. I install and use CODE on my own server. I’m Japanese, but the latest version of Collabora doesn’t allow me to use CODE in Japanese view mode. Collabora is unavailable. I want to go back to Collabora, which is about two generations old. Is there anywhere I can get an old source?.

If user change the NC language to English, it works fine. This is a CODE issue. When I call CODE in another app, it doesn’t work the same way if the app is in Japanese mode.

You talk about the new built in code application in the nextcloud store ? You don’t need configure http server for the new built in code app.

I’m downloading from the App Store. I am running on nginx. I can’t connect to the built-in version of CODE without configure nginx.

1 Like

Yes you can. It’s the goal of the built in code app. You just need the built in code app and the collabora app (just like only office)

I don’t know how to configure nginx.

Ok I said to you that you don’t need to configure nginx with built in app. You can follow this instruction : How to install Collabora Online in Nextcloud Hub

BUT If you install collabora with code server (docker or not), you don’t need built in app and you need to configure nginx with the following instructions https://www.collaboraoffice.com/code/nginx-reverse-proxy/

I want to try the built-in version.

Are the errors indicated by the attached images irrelevant?

Its relevant, your installation doesnt work

Did you install the Built in CODE server app before ?

I am having the same problem

Buit in CODE server app is a new application and its a big application (only available on NC 19). So it’s not surprising

I questioned the relevance of the order in which they were installed. I uninstalled them both once and installed the built-ins first. Then I installed Collabora Online. But the situation remains the same.

coming back to the original question: did someone fixed it?

My current nginx is in the following state, officially introduced by NC.

Collabora’s site has a description that mentions fuse and fontconfig. I have fontconfig installed, but I don’t have fuse installed . Does this affect me?

I have no knowledge of FUSE at all. I installed the fuse related stuff in yum, but of course that’s not enough to make the built-in CODE doesn’t seem to work.

I tried uninstalling CODE once it was installed on my own server. But this doesn’t seem to matter.