About maintenance_window_start=>1 configuration problem

I saw the official introduction about maintenance_window_start=>1 configuration

https://docs.nextcloud.com/server/28/admin_manual/configuration_server/background_jobs_configuration.html .

In the config/config.php file you can specify this config. Some background jobs only run once a day. When an hour is defined (timezone is UTC) for this config, the background jobs which advertise themselves as not time-sensitive will be delayed during the “working” hours and only run in the 4 hours after the given time. This is e.g. used for activity expiration, suspicious login training, and update checks.

A value of 1 e.g. will only run these background jobs between 01:00am UTC and 05:00am UTC:

'maintenance_window_start' => 1,

If you don’t care when these jobs run, you can set the value to 100, but beware that resource intensive jobs may then run unnecessarily during high usage periods. This may lead to slower performance and a lower quality user experience.

This setting may also be set directly via occ just like any other configuration parameter:

occ config:system:set maintenance_window_start --type=integer --value=1

However, I still don’t quite understand how I should configure it if I want to configure it to execute the task at 1 am in the 8am East time zone.

maintenance_window_start=>8

Is that so?

what do you mean with the 8am?
If you talk about the Eastern Time (UTC -4, like for US East coast), if you want to run the maintenance window at 1 am of your local time, in UTC this is 5 am. So you set the value to 5 (if you take it like a formula: ET = UTC-4 => UTC = ET+4).

If you talk about China Standard Time (UTC +8), and you want to run the windows starting at 1 am local time, you set it to 1 am - 8h = 17 (5pm the day before).

2 Likes