526 Invalid SSL certificate after 1 year on AIO


I’ve been using AIO solution for ~1 year and now suddenly I get an invalid SSL certificate (I’m using Cloudflare).

I can’t get to any logs because the AIO version is running in docker and I don’t know the path to it. I guess the certificate on the server expired?

Could you please navigate me to generate a new one?

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

I can't login.

Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): replace me
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04.3 LTS
Apache or nginx version (eg, Apache 2.4.25): replace me
PHP version (eg, 7.4): replace me

The issue you are facing:

Is this the first time you’ve seen this error? Y

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:

I can't login

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

I don't know what's the path as it is in docker

The output of your Apache/nginx/system log in /var/log/____:



Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.


Hi, this reminds me of Issues with renewing SSL certificates · Discussion #1101 · nextcloud/all-in-one · GitHub

1 Like

Wohoo! It worked. Thanks a lot Szaimen.

Solution: disable cloudflare, restart apache container, enable cloudflare :slight_smile: