504 Gateway Timeout during sync

Running NextCloudPi on RPI4 4GB using the stock NCP img for install (Buster)
Nextcloud version : 21.0.4

NextCloud is running on the Apache2 config stock from image–only notable change is static IP assigned

NextCloud is sitting behind an NGNIX reverse proxy running on Raspberry Pi 3B+ (1GB RAM)

This is actually a reinstall after something bombed out with the last installation which had been running for about a year. I tried restoring the NCP config and DB from backups located on the same external disc as the data, but was unable to get that working so started with fresh install.

*As the files are syncing back from my Windows 10 laptop client up to the NC storage large files are getting a 504 Gateway timeout error.

  • The Large Files aren’t particularly large; smaller than the default 10GB limit set in settings. Largest files are still <7GB
  • I do not see anything noted in the logs.
    *Smaller files are syncing fine.

There’s ~350GB of data trying to sync up as my locally stored files are repopulating the cloud storage. It doesn’t seem like a crazy amount.

Is this just an issue with a large amount of data on the initial sync and those files will eventually sync up or are there some settings I need to tweak on either the NextCloud host or the NGNIX reverse proxy to ensure those files can sync up?

I am relatively new to Debian, esp with Apache configs, etc. I’ve looked at a few other posts with 504 errors but it seems that it’s addressing NGINX as a host, not as a reverse proxy when it’s involved but I may be misunderstanding.

If someone could explain what is causing it and what steps I need to do like I am a beginner who is genuinely really trying to learn I would be most appreciative.