503 Service Unavailable after reboot of raspberry pi

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud pi version: v1.51.0
Nextcloud version _(eg, 20.0.5)
Operating system and version _(Raspbery pi 4):

PHP version (eg, 8.1):

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N):Y

Steps to replicate it:

  1. Installed ncp
  2. Everything was working fine for a few months. I had to reboot the raspberry pi
    After the reboot the web interface does not load up and I get 503 Service Unavailable.

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Here is my ncp report:

Hi, I am not a pi specialist but your logfile is definitively saying, that your redis server does not run.

Is the webui / or ncp-config still reachable?

If yes try to clear the op-cache.
Propably that helps.


I used ncp config and cleared thw cache and the wb interface stsrted working immediately.

Thank you so much.

How do I fix the redis server?

Wow clearing the opcache did it.

Thank you so much

Thank you so much!!! You have no idea how long I’ve been trying to fix this!!!

For those who don’t know how to clear the op-cache, type sudo raspi-config
Then go System Options > NextcloudPi Configuration > Tools > [clear-php-opcache] .
Then reboot sudo reboot.