503 error after upgrade from v11.0.2 to v12

Nextcloud version:
Operating system and version: Raspbian GNU/Linux 8 (jessie)
Apache version: Apache/2.4.10 (Raspbian)
PHP version: PHP 5.6.30-0+deb8u1 (cli) (built: Apr 14 2017 16:20:58)
Is this the first time you’ve seen this error?: yes

Can you reliably replicate it? (If so, please outline steps): permanent

I upgraded following the offical documentation “Using the web based Updater” https://docs.nextcloud.com/server/11/admin_manual/maintenance/update.html

In Step 7 I tried to follow on to the “web based upgrade” but instead of the “Start update” page I got a 503 hence I took the alternative step for the “command line based upgrade” “$ sudo -u www-data php ./occ upgrade” to the “finished successfully” message. The 503 error didn’t go away though.

The issue you are facing: 503 error

The output of your nextcloud.log log in /www/nextcloud:

{“reqId”:“s5uoMxQ7AYtOFMrMnx2V”,“level”:4,“time”:“2017-06-03T16:31:10+00:00”,“remoteAddr”:“123.456.789.101”,“user”:"–",“app”:“remote”,“method”:“GET”,“url”:"/status.php",“message”:“Memcache \OC\Memcache\APC not available for local cache”,“userAgent”:“Mozilla/5.0 (Windows) mirall/2.3.0 (build 6780)”,“version”:“”}

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php $CONFIG = array ( 'instanceid' => 'ocxv1mbg1xxb', 'passwordsalt' => '123456', 'secret' => 'kerb/123456', 'trusted_domains' => array ( 0 => 'dyndnsservice.com', 1 => 'mydomain.org', ), 'datadirectory' => '/var/www/nextcloud/data', 'overwrite.cli.url' => 'http://dyndnsservice.com', 'dbtype' => 'mysql', 'version' => '', 'dbname' => 'nextcloud', 'dbhost' => 'localhost', 'dbport' => '', 'dbtableprefix' => 'oc_', 'dbuser' => 'redacted', 'dbpassword' => 'redacted', 'logtimezone' => 'UTC', 'installed' => true, 'memcache.local' => '\\OC\\Memcache\\APC', 'maintenance' => false, 'updater.release.channel' => 'beta', 'updater.secret' => 'redacted', 'loglevel' => 2, ); The output of your Apache/nginx/system log in `/var/log/apache2/error.log`: [Sat Jun 03 06:25:04.963446 2017] [mpm_prefork:notice] [pid 1134] AH00163: Apache/2.4.10 (Raspbian) OpenSSL/1.0.1t configured -- resuming normal operations [Sat Jun 03 06:25:04.963550 2017] [core:notice] [pid 1134] AH00094: Command line: '/usr/sbin/apache2' [Sat Jun 03 17:07:53.133811 2017] [mpm_prefork:notice] [pid 1134] AH00169: caught SIGTERM, shutting down [Sat Jun 03 17:08:19.615024 2017] [mpm_prefork:notice] [pid 15423] AH00163: Apache/2.4.10 (Raspbian) OpenSSL/1.0.1t configured -- resuming normal operations [Sat Jun 03 17:08:19.615218 2017] [core:notice] [pid 15423] AH00094: Command line: '/usr/sbin/apache2' --- Remember, this information may be requested if it isn't supplied; for fastest response please provide as much as you can :heart: Feel free to use a pastebin service, otherwise log files can be indented with 4 spaces on each line to present them in a friendlier way on the forum.

APC is not supported anymore, the PHP module package should anyway be php5-apcu and just emulate APC. Just change the entry in your config.php to APCu and everything will work again :slight_smile:.

1 Like

Thanks a bunch MichaIng, that did it!

Strangely version 11.0.2 was my inital installation. Was ‘memcache.local’ => ‘\OC\Memcache\APC’, not ment to be there? I can’t remember to have messed with that option.

Memcache is not preconfigured if you install manually with zip from https://download.nextcloud.com/server/releases/ nor is it mentioned/supported within the nc 11 admin manual: https://docs.nextcloud.com/server/11/admin_manual/configuration_server/caching_configuration.html

No idea where your config comes from :smiley:, maybe just forgot the “u” while following the server tuning recommendations?